aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-17 18:06:38 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-17 18:06:38 +0800
commitbb7c4c0801dd03088a6b27751ddefaf85d637d32 (patch)
tree1732ff97926b49649caf4656496c8b9ec8cd7ef3 /java
parentfa8085aa5d24fe067837399104df0efd901215e1 (diff)
downloadfreebsd-ports-gnome-bb7c4c0801dd03088a6b27751ddefaf85d637d32.tar.gz
freebsd-ports-gnome-bb7c4c0801dd03088a6b27751ddefaf85d637d32.tar.zst
freebsd-ports-gnome-bb7c4c0801dd03088a6b27751ddefaf85d637d32.zip
Stagify.
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-log4e/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/java/eclipse-log4e/Makefile b/java/eclipse-log4e/Makefile
index a136a5c7a670..7ab67b290bf4 100644
--- a/java/eclipse-log4e/Makefile
+++ b/java/eclipse-log4e/Makefile
@@ -19,15 +19,14 @@ USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
-NO_STAGE= yes
do-install:
- @${MKDIR} -p ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/plugins ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/features ${PREFIX}/lib/eclipse
- @(cd ${WRKSRC}; ${FIND} -s features plugins -not -type d) \
- | ${SED} -ne 's,^,lib/eclipse/,p' >> ${TMPPLIST}
- @(cd ${WRKSRC}; ${FIND} -s -d features plugins -type d) \
- | ${GREP} -vE 'plugins$$|features$$' \
- | ${SED} -ne 's,^,@dirrm lib/eclipse/,p' >> ${TMPPLIST}
+ @${MKDIR} -p ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/plugins ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/features ${STAGEDIR}${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s features plugins -not -type d) \
+ | ${SED} -ne 's,^,lib/eclipse/,p' >> ${TMPPLIST}
+ @(cd ${WRKSRC}; ${FIND} -s -d features plugins -type d) \
+ | ${GREP} -vE 'plugins$$|features$$' \
+ | ${SED} -ne 's,^,@dirrm lib/eclipse/,p' >> ${TMPPLIST}
.include <bsd.port.mk>