aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2010-05-18 21:29:10 +0800
committerale <ale@FreeBSD.org>2010-05-18 21:29:10 +0800
commitd9133c82a4434e85a792bda9649e961cd9706876 (patch)
tree94a003266b2a6c685cd53a43cb881f350938613e /java
parentc11e9cc3548ca562ba1f045d7b3074661b6bdb40 (diff)
downloadfreebsd-ports-gnome-d9133c82a4434e85a792bda9649e961cd9706876.tar.gz
freebsd-ports-gnome-d9133c82a4434e85a792bda9649e961cd9706876.tar.zst
freebsd-ports-gnome-d9133c82a4434e85a792bda9649e961cd9706876.zip
Do not add /usr/local/lib three times to DEFAULT_LIBPATH.
Update cacerts file from Sun's JRE 6u20.
Diffstat (limited to 'java')
-rw-r--r--java/openjdk6/Makefile2
-rw-r--r--java/openjdk6/files/cacertsbin75058 -> 80122 bytes
-rw-r--r--java/openjdk6/files/patch-set6
3 files changed, 3 insertions, 5 deletions
diff --git a/java/openjdk6/Makefile b/java/openjdk6/Makefile
index ea40ffe8acab..a75288a138bf 100644
--- a/java/openjdk6/Makefile
+++ b/java/openjdk6/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openjdk6
PORTVERSION= b19
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= http://download.java.net/openjdk/jdk6/promoted/${PORTVERSION}/ \
${MASTER_SITE_APACHE:S,%SUBDIR%/,ant/binaries/:ant,} \
diff --git a/java/openjdk6/files/cacerts b/java/openjdk6/files/cacerts
index 5f998d1b7517..12d3aa1b024a 100644
--- a/java/openjdk6/files/cacerts
+++ b/java/openjdk6/files/cacerts
Binary files differ
diff --git a/java/openjdk6/files/patch-set b/java/openjdk6/files/patch-set
index d742792941dc..4c8ea1130921 100644
--- a/java/openjdk6/files/patch-set
+++ b/java/openjdk6/files/patch-set
@@ -3441,19 +3441,17 @@
void os::init_system_properties_values() {
// char arch[12];
-@@ -281,10 +356,8 @@
+@@ -281,9 +356,7 @@
* ...
* 7: The default directories, normally /lib and /usr/lib.
*/
-#if defined(AMD64) || defined(_LP64) && (defined(SPARC) || defined(PPC) || defined(S390))
-#define DEFAULT_LIBPATH "/usr/lib64:/lib64:/lib:/usr/lib"
-#else
--#define DEFAULT_LIBPATH "/lib:/usr/lib"
+#ifndef DEFAULT_LIBPATH
-+#define DEFAULT_LIBPATH "/lib:/usr/lib:/usr/local/lib:/usr/local/lib"
+ #define DEFAULT_LIBPATH "/lib:/usr/lib"
#endif
- #define EXTENSIONS_DIR "/lib/ext"
@@ -362,7 +435,11 @@
* should always exist (until the legacy problem cited above is
* addressed).