aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-03-20 22:38:06 +0800
committerhq <hq@FreeBSD.org>2005-03-20 22:38:06 +0800
commitf4f98ad61580b698efe5972837abf13268421d30 (patch)
treeb909c03fa082224e9701e414edf4dd92ee5d1840 /java
parent34664206d7767e1e05dd101a4b30e593dc190675 (diff)
downloadfreebsd-ports-gnome-f4f98ad61580b698efe5972837abf13268421d30.tar.gz
freebsd-ports-gnome-f4f98ad61580b698efe5972837abf13268421d30.tar.zst
freebsd-ports-gnome-f4f98ad61580b698efe5972837abf13268421d30.zip
- Install Sun Code Conventions sample file [1]
- Disable jikes PR: 78229 [1] Submitted by: Daniel Grund <daniel@dgrund.de> [1] Approved by: maintainer timeout
Diffstat (limited to 'java')
-rw-r--r--java/java-checkstyle/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/java/java-checkstyle/Makefile b/java/java-checkstyle/Makefile
index 553bbf89ffff..4c0ffe4d4105 100644
--- a/java/java-checkstyle/Makefile
+++ b/java/java-checkstyle/Makefile
@@ -7,6 +7,7 @@
PORTNAME= checkstyle
PORTVERSION= 3.5
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,12 +23,14 @@ USE_JAVA= yes
JAVA_VERSION= 1.4+
USE_ANT= yes
ALL_TARGET= build.bindist
+USE_JIKES= no
PLIST= ${WRKDIR}/PLIST
STYLEDIR= ${JAVASHAREDIR}/${PORTNAME}
-PLIST_FILES= bin/checkstyle %%JAVAJARDIR%%/${PORTNAME}.jar %%JAVAJARDIR%%/${PORTNAME}-optional.jar
+PLIST_FILES= bin/checkstyle %%JAVAJARDIR%%/${PORTNAME}.jar %%JAVAJARDIR%%/${PORTNAME}-optional.jar \
+ ${STYLEDIR:S,${PREFIX}/,,}/examples/conf/sun_checks.xml
.if !defined(NOPORTDOCS)
BUILDDIR= ${WRKSRC}/target/dist/${PORTNAME}-${PORTVERSION}
PORTDOCS= README LICENSE* TODO RIGHTS* docs
@@ -57,6 +60,7 @@ do-install-data:
@${MKDIR} ${STYLEDIR}
@${CP} -r ${BUILDDIR}/contrib/* ${STYLEDIR}
@${CHOWN} -h -R ${SHAREOWN}:${SHAREGRP} ${STYLEDIR}
+ @${INSTALL_DATA} ${WRKSRC}/sun_checks.xml ${STYLEDIR}/examples/conf/
do-install-apidocs:
.if !defined(NOPORTDOCS)