aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2009-02-19 11:32:00 +0800
committerlioux <lioux@FreeBSD.org>2009-02-19 11:32:00 +0800
commit08a02c76de0c7f2a69a35336a99d967b0f8fc062 (patch)
treee800b95f8527bb0fe29583f854dca16bb4ecd064 /java
parentcc7a4c99b4e25f592078ec3954e6fa3ecbf6f28f (diff)
downloadfreebsd-ports-gnome-08a02c76de0c7f2a69a35336a99d967b0f8fc062.tar.gz
freebsd-ports-gnome-08a02c76de0c7f2a69a35336a99d967b0f8fc062.tar.zst
freebsd-ports-gnome-08a02c76de0c7f2a69a35336a99d967b0f8fc062.zip
o Remove BROKEN by not installing files already installed by
dependencies o Bump PORTREVISION since PLIST has been changed (it is generated post install) PR: 131577
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-webtools/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/java/eclipse-webtools/Makefile b/java/eclipse-webtools/Makefile
index 8ebf0226ace4..edf486b4f420 100644
--- a/java/eclipse-webtools/Makefile
+++ b/java/eclipse-webtools/Makefile
@@ -7,6 +7,7 @@
PORTNAME= webtools
PORTVERSION= 2.0.3
+PORTREVISION= 1
CATEGORIES= java devel www
MASTER_SITES= ${MASTER_SITE_ECLIPSE:S,/eclipse/downloads/drops/,/webtools/downloads/drops/,}
MASTER_SITE_SUBDIR= R2.0/R-${PORTVERSION}-20080710044639/
@@ -21,8 +22,6 @@ RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
${LOCALBASE}/eclipse/features/org.eclipse.emf_2.3.2.v200802051830/feature.xml:${PORTSDIR}/java/eclipse-emf \
${LOCALBASE}/eclipse/features/org.eclipse.gef_3.3.2.v20080129/feature.xml:${PORTSDIR}/java/eclipse-gef
-BROKEN= deletes files installed by dependency on deinstall
-
CONFLICTS= eclipse-lomboz-3.*
NO_BUILD= yes
@@ -32,6 +31,18 @@ USE_JAVA= yes
JAVA_VERSION= 1.5+
JAVA_OS= native
+# remove files that already exist on the RUN_DEPENDS java/eclipse port
+REMOVE_DUPLICATE_FILES= \
+ eclipse/plugins/javax.servlet.jsp_2.0.0.v200706191603.jar \
+ eclipse/plugins/javax.servlet_2.4.0.v200706111738.jar \
+ eclipse/plugins/org.apache.commons.el_1.0.0.v200706111724.jar \
+ eclipse/plugins/org.apache.commons.logging_1.0.4.v200706111724.jar
+
+post-extract:
+.for file in ${REMOVE_DUPLICATE_FILES}
+ @${RM} -f ${WRKSRC}/${file}
+.endfor
+
do-install:
@${MKDIR} ${PREFIX}/eclipse
@${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse