aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2012-09-21 23:23:56 +0800
committerglewis <glewis@FreeBSD.org>2012-09-21 23:23:56 +0800
commit08dd2ecebd7e911155fb74da35a61b0f074eb988 (patch)
tree4180ce34c6e3519467b3b8e24729b18d417d6c91 /java
parentc3a98cd9427e169dbeb7a83f8381e8ab6506a6c3 (diff)
downloadfreebsd-ports-gnome-08dd2ecebd7e911155fb74da35a61b0f074eb988.tar.gz
freebsd-ports-gnome-08dd2ecebd7e911155fb74da35a61b0f074eb988.tar.zst
freebsd-ports-gnome-08dd2ecebd7e911155fb74da35a61b0f074eb988.zip
. Also fix permissions in the dropins/jdt/plugins directory.
Pointed out by: ale@
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-devel/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/java/eclipse-devel/Makefile b/java/eclipse-devel/Makefile
index e5d944ef47de..ca4072acda83 100644
--- a/java/eclipse-devel/Makefile
+++ b/java/eclipse-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= eclipse-devel
PORTVERSION= 4.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= java devel
MASTER_SITES= http://download.eclipse.org/technology/linuxtools/eclipse-build/4.2.x/:1 \
http://download.eclipse.org/tools/orbit/downloads/drops/R20120119162704/repository/plugins/:2 \
@@ -282,7 +282,9 @@ do-install:
@${MKDIR} ${PORTDESTDIR}
@${MKDIR} ${PREFIX}/${DROPINS_DIR}
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${ANT} ${MAKE_ARGS} ${INSTALL_TARGET})
- @${FIND} ${PORTDESTDIR}/plugins -type f -perm 600 -print0 | ${XARGS} -0 ${CHMOD} 644
+.for d in plugins dropins/jdt/plugins
+ @${FIND} ${PORTDESTDIR}/${d} -type f -perm 600 -print0 | ${XARGS} -0 ${CHMOD} 644
+.endfor
@${SED} \
-e "s+%%BROWSER%%+${GECKO:S/19//}+g" \
-e "s+%%ECLIPSE_HOME%%+${PORTDESTDIR}+g" \