aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-02-24 09:44:34 +0800
committerwen <wen@FreeBSD.org>2010-02-24 09:44:34 +0800
commit88b7d0e86d7d4ab89f2ab2c60b72d0d88a6592c4 (patch)
treeab91c1e5e40e542ff0cdd88dd428d33fccf1fe0e /java
parentba0910f1ac29fbdebe84cd93476f0083be8685df (diff)
downloadfreebsd-ports-gnome-88b7d0e86d7d4ab89f2ab2c60b72d0d88a6592c4.tar.gz
freebsd-ports-gnome-88b7d0e86d7d4ab89f2ab2c60b72d0d88a6592c4.tar.zst
freebsd-ports-gnome-88b7d0e86d7d4ab89f2ab2c60b72d0d88a6592c4.zip
JRosetta provides a common base for graphical component that could be used
to build a graphical console in Swing with the latest requirements, such as command history, completion and so on for instance for scripting language or command line. This project can be seen as the evolution of the components developed in JyConsole. For now, JRosetta provides only API and graphical components. A Jython implementation for the scripting engine should be available during the first semester 2009. Functionalities * Generic abstract API for script engine * Completion window. * Command history. * Highly customisable, with external XML descriptor file. (Allow to specify the script engine to use, colors, font, shortcut...) Platform compatibility * JRosetta has been developed in pure Java, but relies on a JVM 1.5. * No specific hardware is needed. For further information, please contact us at the following adress : contact at artenum.com WWW: http://dev.artenum.com/projects/JRosetta Feature safe: yes
Diffstat (limited to 'java')
-rw-r--r--java/Makefile1
-rw-r--r--java/jrosetta/Makefile33
-rw-r--r--java/jrosetta/distinfo3
-rw-r--r--java/jrosetta/pkg-descr23
4 files changed, 60 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index d3e71956404f..9ffc4a3376e3 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -124,6 +124,7 @@
SUBDIR += jmp
SUBDIR += jode
SUBDIR += jomp
+ SUBDIR += jrosetta
SUBDIR += jsdk
SUBDIR += jtiger
SUBDIR += jump
diff --git a/java/jrosetta/Makefile b/java/jrosetta/Makefile
new file mode 100644
index 000000000000..783f2daea020
--- /dev/null
+++ b/java/jrosetta/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: jrosetta
+# Date created: 11 February 2010
+# Whom: rfarmer@predatorlabs.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= jrosetta
+PORTVERSION= 1.0.2
+CATEGORIES= java devel
+MASTER_SITES= http://www.predatorlabs.net/dl/
+EXTRACT_SUFX= -gpl.zip
+
+MAINTAINER= rfarmer@predatorlabs.net
+COMMENT= API for building a graphical console in Swing
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+JAVA_BUILD= yes
+JAVA_RUN= yes
+USE_ANT= yes
+
+ALL_TARGET= make
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-gpl
+
+PLIST_FILES= %%JAVAJARDIR%%/jrosetta-API.jar \
+ %%JAVAJARDIR%%/jrosetta-engine.jar
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/dist/jrosetta-API.jar ${JAVAJARDIR}
+ ${INSTALL_DATA} ${WRKSRC}/dist/jrosetta-engine.jar ${JAVAJARDIR}
+
+.include <bsd.port.mk>
diff --git a/java/jrosetta/distinfo b/java/jrosetta/distinfo
new file mode 100644
index 000000000000..fd886b5bc24e
--- /dev/null
+++ b/java/jrosetta/distinfo
@@ -0,0 +1,3 @@
+MD5 (jrosetta-1.0.2-gpl.zip) = 3a618078c118216eb2351e5db6e14a7d
+SHA256 (jrosetta-1.0.2-gpl.zip) = 1d8a1de967ca00109b92dedc16bc27ceb68e61aea25f6ba9dc6f977d8d636c8d
+SIZE (jrosetta-1.0.2-gpl.zip) = 69552
diff --git a/java/jrosetta/pkg-descr b/java/jrosetta/pkg-descr
new file mode 100644
index 000000000000..94809944d2fc
--- /dev/null
+++ b/java/jrosetta/pkg-descr
@@ -0,0 +1,23 @@
+JRosetta provides a common base for graphical component that could be used
+to build a graphical console in Swing with the latest requirements, such
+as command history, completion and so on for instance for scripting language
+or command line. This project can be seen as the evolution of the components
+developed in JyConsole. For now, JRosetta provides only API and graphical
+components. A Jython implementation for the scripting engine should be
+available during the first semester 2009.
+
+Functionalities
+* Generic abstract API for script engine
+* Completion window.
+* Command history.
+* Highly customisable, with external XML descriptor file. (Allow to specify
+ the script engine to use, colors, font, shortcut...)
+
+Platform compatibility
+* JRosetta has been developed in pure Java, but relies on a JVM 1.5.
+* No specific hardware is needed.
+
+For further information, please contact us at the following adress :
+contact at artenum.com
+
+WWW: http://dev.artenum.com/projects/JRosetta