aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2009-03-20 01:28:51 +0800
committerbsam <bsam@FreeBSD.org>2009-03-20 01:28:51 +0800
commitb5b6ef339af6e9567c4016e6901e2bfe99d8929d (patch)
treeae0eafd06267e327a81b96ea5185410d99119e0b /java
parent0204725af4e2f2a52e65017bb4dc7820bee39bab (diff)
downloadfreebsd-ports-gnome-b5b6ef339af6e9567c4016e6901e2bfe99d8929d.tar.gz
freebsd-ports-gnome-b5b6ef339af6e9567c4016e6901e2bfe99d8929d.tar.zst
freebsd-ports-gnome-b5b6ef339af6e9567c4016e6901e2bfe99d8929d.zip
Welcome to the new linux ports infrastructure which allows using
both current (fc4) and future linux (f8) distributions at one ports tree. The patch contains full changes to ports/Mk files and all ports involved. But only infrastructure is changed. The resulting packages are the same as before. Hence no need to bump PORTREVISIONs. The idea was taken from bsd.gnome.mk and others. More than 130 ports are switched to follow a new linux infrastructure introduced by changes to bsd.port.mk, bsd.linux-rpm.mk and a new bsd.linux-apps.mk. Thanks for all who was involved and helped me with this work. And help from Alexander Leidinger was incredible. Other changes are coming. Stay tuned! PR: ports/132510 Submitted by: bsam (me) Exp-run by: portmgr (pav)
Diffstat (limited to 'java')
-rw-r--r--java/linux-blackdown-jdk14/Makefile2
-rw-r--r--java/linux-sun-jdk13/Makefile2
-rw-r--r--java/linux-sun-jdk14/Makefile2
-rw-r--r--java/linux-sun-jdk15/Makefile2
-rw-r--r--java/linux-sun-jdk16/Makefile2
-rw-r--r--java/linux-sun-jre15/Makefile2
-rw-r--r--java/linux-sun-jre16/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/java/linux-blackdown-jdk14/Makefile b/java/linux-blackdown-jdk14/Makefile
index 5d484eccf55f..bfbcc4ee99b6 100644
--- a/java/linux-blackdown-jdk14/Makefile
+++ b/java/linux-blackdown-jdk14/Makefile
@@ -25,7 +25,7 @@ EXTRACT_BEFORE_ARGS= +592
EXTRACT_AFTER_ARGS= | ${BZIP2_CMD} -dc | ${TAR} xf -
USE_BZIP2= yes
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= xorglibs
LATEST_LINK= linux-blackdown-jdk14
WRKSRC= ${WRKDIR}/j2sdk${PORTVERSION}
diff --git a/java/linux-sun-jdk13/Makefile b/java/linux-sun-jdk13/Makefile
index 46a2603dd8b0..2318a18ac3cf 100644
--- a/java/linux-sun-jdk13/Makefile
+++ b/java/linux-sun-jdk13/Makefile
@@ -29,7 +29,7 @@ PLIST_SUB+= T=${TARGET_DIR:S/^${PREFIX}\///} \
NO_BUILD= yes
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= xorglibs
JDK_VERSION= 1.3.1
JDK_REVISION= 18
ONLY_FOR_ARCHS= i386 amd64
diff --git a/java/linux-sun-jdk14/Makefile b/java/linux-sun-jdk14/Makefile
index 01e1e0497384..b897409a18a7 100644
--- a/java/linux-sun-jdk14/Makefile
+++ b/java/linux-sun-jdk14/Makefile
@@ -29,7 +29,7 @@ PKGINSTALL= ${WRKDIR}/pkg-install
NO_BUILD= yes
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= xorglibs
JDK_VERSION= 1.4.2
JDK_REVISION= 18
DL_JDK_VERSION= ${JDK_VERSION}_${JDK_REVISION}
diff --git a/java/linux-sun-jdk15/Makefile b/java/linux-sun-jdk15/Makefile
index 2e828b00c9f7..2b5824d36553 100644
--- a/java/linux-sun-jdk15/Makefile
+++ b/java/linux-sun-jdk15/Makefile
@@ -30,7 +30,7 @@ PKGINSTALL= ${WRKDIR}/pkg-install
NO_BUILD= yes
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= xorglibs
JDK_VERSION= 1.5.0
JDK_REVISION= 16
DL_JDK_VERSION= ${JDK_VERSION}_${JDK_REVISION}
diff --git a/java/linux-sun-jdk16/Makefile b/java/linux-sun-jdk16/Makefile
index e176a4a8fb49..cdec0845760e 100644
--- a/java/linux-sun-jdk16/Makefile
+++ b/java/linux-sun-jdk16/Makefile
@@ -29,7 +29,7 @@ PKGINSTALL= ${WRKDIR}/pkg-install
NO_BUILD= yes
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= xorglibs
JDK_VERSION= 1.6.0
JDK_REVISION= 10
DL_JDK_VERSION= ${JDK_VERSION}_${JDK_REVISION}
diff --git a/java/linux-sun-jre15/Makefile b/java/linux-sun-jre15/Makefile
index f38a58842e4a..863a20916ef6 100644
--- a/java/linux-sun-jre15/Makefile
+++ b/java/linux-sun-jre15/Makefile
@@ -29,7 +29,7 @@ PKGINSTALL= ${WRKDIR}/pkg-install
NO_BUILD= yes
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= xorglibs
JRE_VERSION= 1.5.0
JRE_REVISION= 13
DL_JRE_VERSION= ${JRE_VERSION}_${JRE_REVISION}
diff --git a/java/linux-sun-jre16/Makefile b/java/linux-sun-jre16/Makefile
index c063c83fecf8..7f02b5223347 100644
--- a/java/linux-sun-jre16/Makefile
+++ b/java/linux-sun-jre16/Makefile
@@ -29,7 +29,7 @@ PKGINSTALL= ${WRKDIR}/pkg-install
NO_BUILD= yes
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= xorglibs
JRE_VERSION= 1.6.0
JRE_REVISION= 03
DL_JRE_VERSION= ${JRE_VERSION}_${JRE_REVISION}