aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2017-07-11 21:20:17 +0800
committertobik <tobik@FreeBSD.org>2017-07-11 21:20:17 +0800
commit2272d8b13ccbe8ad1a8e222eb35027849d203e1b (patch)
tree2cba6703c1e2ed9c0109bed62692e88d1987ff75 /java
parent5f441f462042346362fd926435d8f185c3e1174a (diff)
downloadfreebsd-ports-gnome-2272d8b13ccbe8ad1a8e222eb35027849d203e1b.tar.gz
freebsd-ports-gnome-2272d8b13ccbe8ad1a8e222eb35027849d203e1b.tar.zst
freebsd-ports-gnome-2272d8b13ccbe8ad1a8e222eb35027849d203e1b.zip
Add missing Pango symbols
Currently Pango functions are hidden behind __linux__ and not compiled in as part of the build. Not all JavaFX applications are affected by this, but applications that do advanced text layout that require Pango internally cause an UnsatisfiedLinkError at runtime. Caused by: java.lang.UnsatisfiedLinkError: com.sun.javafx.font.freetype.OSPango.pango_ft2_font_map_new()J at com.sun.javafx.font.freetype.OSPango.pango_ft2_font_map_new(Native Method) at com.sun.javafx.font.freetype.PangoGlyphLayout.layout(PangoGlyphLayout.java:88) at com.sun.javafx.text.PrismTextLayout.shape(PrismTextLayout.java:834) at com.sun.javafx.text.PrismTextLayout.layout(PrismTextLayout.java:1064) at com.sun.javafx.text.PrismTextLayout.ensureLayout(PrismTextLayout.java:223) ... PR: 220566 Submitted by: Stefan Ehmann <shoesoft@gmx.net> Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D11545 MFH: 2017Q3
Diffstat (limited to 'java')
-rw-r--r--java/openjfx8-devel/Makefile2
-rw-r--r--java/openjfx8-devel/files/patch-modules_graphics_src_main_native-font_pango.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/java/openjfx8-devel/Makefile b/java/openjfx8-devel/Makefile
index 44da4f6e5985..ed8f212070d9 100644
--- a/java/openjfx8-devel/Makefile
+++ b/java/openjfx8-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openjfx8
PORTVERSION= 20160228
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= java x11-toolkits devel
MASTER_SITES= https://bitbucket.org/tobik/openjfx-rt/get/ \
http://bitbucket.org/tobik/openjfx-rt/get/
diff --git a/java/openjfx8-devel/files/patch-modules_graphics_src_main_native-font_pango.c b/java/openjfx8-devel/files/patch-modules_graphics_src_main_native-font_pango.c
new file mode 100644
index 000000000000..369562a9ffe2
--- /dev/null
+++ b/java/openjfx8-devel/files/patch-modules_graphics_src_main_native-font_pango.c
@@ -0,0 +1,11 @@
+--- modules/graphics/src/main/native-font/pango.c.orig 2017-07-08 13:12:21 UTC
++++ modules/graphics/src/main/native-font/pango.c
+@@ -23,7 +23,7 @@
+ * questions.
+ */
+
+-#if defined __linux__
++#if defined __linux__ || defined(__FreeBSD__)
+ #if defined _ENABLE_PANGO
+
+ #include <jni.h>