aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2013-09-09 04:56:37 +0800
committercrees <crees@FreeBSD.org>2013-09-09 04:56:37 +0800
commit2bf8f095a94c3bad910307354d7c83cd09e39421 (patch)
tree1bd44791d2674e781d2766648d50a1ca1f62fba0 /java
parent1385805a4869f85df667cac7ea69d5ce832488cf (diff)
downloadfreebsd-ports-gnome-2bf8f095a94c3bad910307354d7c83cd09e39421.tar.gz
freebsd-ports-gnome-2bf8f095a94c3bad910307354d7c83cd09e39421.tar.zst
freebsd-ports-gnome-2bf8f095a94c3bad910307354d7c83cd09e39421.zip
The format for bind.address has changed, so document and alert users.
At the same time, fix some errors for logging in the rc script. PR: ports/179927 Submitted by: Alexander Yerenkow <yerenkow@gmail.com> (maintainer)
Diffstat (limited to 'java')
-rw-r--r--java/jboss72/Makefile3
-rw-r--r--java/jboss72/files/jboss72.in10
-rw-r--r--java/jboss72/pkg-message8
3 files changed, 17 insertions, 4 deletions
diff --git a/java/jboss72/Makefile b/java/jboss72/Makefile
index d49c1a480c0c..9769ffded752 100644
--- a/java/jboss72/Makefile
+++ b/java/jboss72/Makefile
@@ -55,6 +55,9 @@ do-build:
do-install:
${MKDIR} ${PREFIX}/${DISTNAME} && cd ${JBOSSOUTPUT} && ${FIND} . | ${CPIO} -pdmu -R ${USER}:${GROUP} ${PREFIX}/${DISTNAME}
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800000
diff --git a/java/jboss72/files/jboss72.in b/java/jboss72/files/jboss72.in
index 61f0293bf62e..07b51fb7d81a 100644
--- a/java/jboss72/files/jboss72.in
+++ b/java/jboss72/files/jboss72.in
@@ -11,9 +11,9 @@
# Add the following lines to /etc/rc.conf to enable %%APP_SHORTNAME%%:
# %%APP_SHORTNAME%%_enable (bool): Set to "YES" to enable %%APP_SHORTNAME%%
-# %%APP_SHORTNAME%%_jvm_opts (str): Extra JVM flags.
# %%APP_SHORTNAME%%_args (str): Optional arguments to JBoss
-# %%APP_SHORTNAME%%_logging (str) JBoss log output. A pipe command may be used.
+# %%APP_SHORTNAME%%_log_stdout (str) JBoss log output stdout, filename.
+# %%APP_SHORTNAME%%_log_stderr (str) JBoss log output stderr, filename.
#
. /etc/rc.subr
@@ -24,7 +24,9 @@ rcvar=%%APP_SHORTNAME%%_enable
load_rc_config $name
%%APP_SHORTNAME%%_enable="${%%APP_SHORTNAME%%_enable:-"NO"}"
-%%APP_SHORTNAME%%_logging="${%%APP_SHORTNAME%%_logging:-">> ${%%APP_SHORTNAME%%_logdir}/stdout.log 2>> ${%%APP_SHORTNAME%%_logdir}/stderr.log"}"
+%%APP_SHORTNAME%%_log_stdout="${%%APP_SHORTNAME%%_log_stdout:-"${%%APP_SHORTNAME%%_logdir}/stdout.log"}"
+%%APP_SHORTNAME%%_log_stderr="${%%APP_SHORTNAME%%_log_stderr:-"${%%APP_SHORTNAME%%_logdir}/stderr.log"}"
+%%APP_SHORTNAME%%_args="${%%APP_SHORTNAME%%_args:-""}"
%%APP_SHORTNAME%%_sleep="${%%APP_SHORTNAME%%_sleep:-"5"}"
%%APP_SHORTNAME%%_kill9="${%%APP_SHORTNAME%%_kill9:-""}"
%%APP_SHORTNAME%%_additional_killall="${%%APP_SHORTNAME%%_additional_killall:-""}"
@@ -45,7 +47,7 @@ JBOSS_HOME="%%APP_HOME%%"
fi
echo "Starting %%APP_SHORTNAME%%."
- daemon -u ${%%APP_SHORTNAME%%_user} ${JBOSS_HOME}/bin/standalone.sh ${%%APP_SHORTNAME%%_logging} >> ${%%APP_SHORTNAME%%_logdir}/boot.log 2>> ${%%APP_SHORTNAME%%_logdir}/boot.log
+ daemon -u ${%%APP_SHORTNAME%%_user} ${JBOSS_HOME}/bin/standalone.sh ${%%APP_SHORTNAME%%_args} >> ${%%APP_SHORTNAME%%_log_stdout} 2>> ${%%APP_SHORTNAME%%_log_stderr} >> ${%%APP_SHORTNAME%%_logdir}/boot.log 2>> ${%%APP_SHORTNAME%%_logdir}/boot.log
sleep ${%%APP_SHORTNAME%%_sleep} # let daemon(8) and sh(1) finish before executing pgrep(1)
pgrep -U ${%%APP_SHORTNAME%%_user} -f ${JBOSS_HOME}/modules > ${pidfile}
diff --git a/java/jboss72/pkg-message b/java/jboss72/pkg-message
new file mode 100644
index 000000000000..1d2d571f0290
--- /dev/null
+++ b/java/jboss72/pkg-message
@@ -0,0 +1,8 @@
+To make JBoss bind to all interfaces add this to /etc/rc.conf:
+
+jboss72_args="-Djboss.bind.address=0.0.0.0"
+
+Old format (-b 0.0.0.0 are not working in 7.2).
+
+You can also specify any other tunables which could be parsed by start scripts.
+To change JVM args, edit appropriate standalone.conf.