aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-11-30 14:13:34 +0800
committerlinimon <linimon@FreeBSD.org>2017-11-30 14:13:34 +0800
commit3e6feb882b8ecd82ccb42e65f86b0f20c69688cc (patch)
tree10dd7508accfa6a3ffc8e631ba63a22cc2fdeb6b /java
parent2c3118177acad05f016f169cb3102633c558c602 (diff)
downloadfreebsd-ports-gnome-3e6feb882b8ecd82ccb42e65f86b0f20c69688cc.tar.gz
freebsd-ports-gnome-3e6feb882b8ecd82ccb42e65f86b0f20c69688cc.tar.zst
freebsd-ports-gnome-3e6feb882b8ecd82ccb42e65f86b0f20c69688cc.zip
For ports that are marked BROKEN on armv6, and also fail to build on
armv7, mark them so. This is part two of a multipart commit to bring armv7 ports to parity with armv6. Approved by: portmgr (tier-2 blanket) Obtained from: lonesome.com -exp run
Diffstat (limited to 'java')
-rw-r--r--java/berkeley-db/Makefile1
-rw-r--r--java/classpath/Makefile1
-rw-r--r--java/jakarta-regexp/Makefile1
-rw-r--r--java/java-cup/Makefile1
-rw-r--r--java/java3d/Makefile1
-rw-r--r--java/jcommon/Makefile1
-rw-r--r--java/sigar/Makefile1
7 files changed, 7 insertions, 0 deletions
diff --git a/java/berkeley-db/Makefile b/java/berkeley-db/Makefile
index 9bffd23f1903..f4cfc92b8c77 100644
--- a/java/berkeley-db/Makefile
+++ b/java/berkeley-db/Makefile
@@ -14,6 +14,7 @@ COMMENT= Berkeley DB Java Edition
BUILD_DEPENDS= ${JAVALIBDIR}/junit.jar:java/junit
BROKEN_armv6= fails to build: build.xml: Java returned: 1
+BROKEN_armv7= fails to build: build.xml: Java returned: 1
OPTIONS_DEFINE= DOCS EXAMPLES TEST
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
index 4f06450ac9a5..4eed1dcd7f64 100644
--- a/java/classpath/Makefile
+++ b/java/classpath/Makefile
@@ -17,6 +17,7 @@ LICENSE= GPLv2
BROKEN_aarch64= fails to configure: error: The jar tool /usr/local/bin/gjar5 was not found
BROKEN_armv6= fails to configure: error: The jar tool /usr/local/bin/gjar5 was not found
+BROKEN_armv7= fails to configure: error: The jar tool /usr/local/bin/gjar5 was not found
BROKEN_powerpc64= fails to configure: error: The jar tool /usr/local/bin/gjar5 was not found
GNU_CONFIGURE= yes
diff --git a/java/jakarta-regexp/Makefile b/java/jakarta-regexp/Makefile
index 90cb8da28003..fc8d261b63e8 100644
--- a/java/jakarta-regexp/Makefile
+++ b/java/jakarta-regexp/Makefile
@@ -11,6 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Regular expressions for Java
BROKEN_armv6= fails to build: build.xml: Java returned: 1
+BROKEN_armv7= fails to build: build.xml: Java returned: 1
USE_JAVA= yes
JAVA_VERSION= 1.6+
diff --git a/java/java-cup/Makefile b/java/java-cup/Makefile
index 6ad27ab0261a..f55b93d2f756 100644
--- a/java/java-cup/Makefile
+++ b/java/java-cup/Makefile
@@ -14,6 +14,7 @@ MAINTAINER= eg@fbsd.lt
COMMENT= LALR parser generator in Java
BROKEN_armv6= fails to build: build.xml: Java returned: 1
+BROKEN_armv7= fails to build: build.xml: Java returned: 1
USE_JAVA= yes
USE_ANT= yes
diff --git a/java/java3d/Makefile b/java/java3d/Makefile
index 345db3ff069f..4490ed46a9f2 100644
--- a/java/java3d/Makefile
+++ b/java/java3d/Makefile
@@ -14,6 +14,7 @@ LICENSE= BSD2CLAUSE GPLv2
LICENSE_COMB= multi
BROKEN_armv6= fails to compile: build.xml: Compile failed; see the compiler error output for details
+BROKEN_armv7= fails to compile: build.xml: Compile failed; see the compiler error output for details
USES= tar:bzip2
USE_JAVA= yes
diff --git a/java/jcommon/Makefile b/java/jcommon/Makefile
index e87db7375f46..3fdd1ad19099 100644
--- a/java/jcommon/Makefile
+++ b/java/jcommon/Makefile
@@ -12,6 +12,7 @@ COMMENT= Collection of useful classes used by JFreeChart and JFreeReport
LICENSE= LGPL21
BROKEN_armv6= fails to package: find: *: No such file or directory
+BROKEN_armv7= fails to package: find: *: No such file or directory
USES= zip
USE_JAVA= yes
diff --git a/java/sigar/Makefile b/java/sigar/Makefile
index 429e392f1895..c8a16f3117ad 100644
--- a/java/sigar/Makefile
+++ b/java/sigar/Makefile
@@ -17,6 +17,7 @@ BUILD_DEPENDS= ${ANT_CMD}:devel/apache-ant
LIB_DEPENDS= libsigar.so:devel/sigar
BROKEN_armv6= fails to compile: jni-build.xml: gcc failed with return code 1
+BROKEN_armv7= fails to compile: jni-build.xml: gcc failed with return code 1
USE_GITHUB= yes
GH_ACCOUNT= amishHammer