aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2004-05-30 11:41:00 +0800
committerlinimon <linimon@FreeBSD.org>2004-05-30 11:41:00 +0800
commit5118215ed9c108747f1d79161e26d7ea263832bb (patch)
tree9d47a630c0c90538dbe7eba1b5936c48ab90f896 /java
parenta4eb8f0596720be6256131d0091377300a87f4f4 (diff)
downloadfreebsd-ports-gnome-5118215ed9c108747f1d79161e26d7ea263832bb.tar.gz
freebsd-ports-gnome-5118215ed9c108747f1d79161e26d7ea263832bb.tar.zst
freebsd-ports-gnome-5118215ed9c108747f1d79161e26d7ea263832bb.zip
Upgrade to 0.9.18. Tweak original port a little according to ports'
CHANGES file. Assign maintainership. PR: ports/67322 Submitted by: Sepherosa Ziehau <sepherosa at softhome.org>
Diffstat (limited to 'java')
-rw-r--r--java/jfreechart/Makefile49
-rw-r--r--java/jfreechart/distinfo4
2 files changed, 44 insertions, 9 deletions
diff --git a/java/jfreechart/Makefile b/java/jfreechart/Makefile
index c7b53b55e7ac..5a40fe688c0d 100644
--- a/java/jfreechart/Makefile
+++ b/java/jfreechart/Makefile
@@ -7,34 +7,66 @@
#
PORTNAME= jfreechart
-PORTVERSION= 0.9.16
+PORTVERSION= 0.9.18
CATEGORIES= java
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sepherosa@softhome.net
COMMENT= A free Java class library for generating charts
-BUILD_DEPENDS= ${ANT}:${PORTSDIR}/devel/apache-ant
+USE_JAVA= yes
+JAVA_VERSION= 1.2+
-PLIST_FILES= share/java/classes/jfreechart.jar
-USE_JAVA= 1.2+
+RUN_DEPENDS= ${JAVAJARDIR}/log4j.jar:${PORTSDIR}/java/jakarta-log4j \
+ ${JAVAJARDIR}/jcommon.jar:${PORTSDIR}/java/jcommon
-ANT?= ${LOCALBASE}/bin/ant
+.if !defined(WITHOUT_COMPILE) || !defined(NOPORTDOCS)
+BUILD_DEPENDS= ${ANT_CMD}:${PORTSDIR}/devel/apache-ant
+ANT_CMD?= ${LOCALBASE}/bin/ant
+ANT= ${SETENV} JAVA_HOME=${JAVA_HOME} ${ANT_CMD}
+.endif
+.if !defined(WITHOUT_COMPILE)
+JAVA_BUILD= yes
ANT_TARGETS= compile
+.else
+JAVA_RUN= yes
+.endif
+
.if !defined(NOPORTDOCS)
ANT_TARGETS+= javadoc
PORTDOCS= *
.endif
+EXTRAJARS= gnujaxp.jar
+
+PLIST_FILES= share/java/classes/jfreechart.jar \
+ share/java/classes/gnujaxp.jar
+
+pre-fetch:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You may use the following build options:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITHOUT_COMPILE=yes Install the pre-compiled .jar file"
+ @${ECHO_MSG} ""
+
do-build:
+.if !defined(WITHOUT_COMPILE) || !defined(NOPORTDOCS)
@cd ${WRKSRC}/ant && ${ANT} ${ANT_TARGETS}
+.endif
+
+do-install: do-install-jar do-install-javadoc
-do-install:
+do-install-jar:
@${ECHO_CMD} -n ">> Installing .jar file..."
@${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-${PORTVERSION}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @for exjar in ${EXTRAJARS}; do \
+ ${INSTALL_DATA} ${WRKSRC}/lib/$$exjar ${JAVAJARDIR} ; \
+ done
@${ECHO_CMD} " [DONE]"
+
+do-install-javadoc:
.if !defined(NOPORTDOCS)
@${ECHO_CMD} -n ">> Installing documentation in ${DOCSDIR}..."
@${MKDIR} ${DOCSDIR}
@@ -43,4 +75,7 @@ do-install:
@${ECHO_CMD} " [DONE]"
.endif
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>
diff --git a/java/jfreechart/distinfo b/java/jfreechart/distinfo
index cd5fe2e04f67..794c83544404 100644
--- a/java/jfreechart/distinfo
+++ b/java/jfreechart/distinfo
@@ -1,2 +1,2 @@
-MD5 (jfreechart-0.9.16.tar.gz) = 3060af9fae4c3458dfd3b93744302d67
-SIZE (jfreechart-0.9.16.tar.gz) = 2326963
+MD5 (jfreechart-0.9.18.tar.gz) = 94919423c48d1495a1bc3250bd861857
+SIZE (jfreechart-0.9.18.tar.gz) = 3353857
an>1-1/+1 * ftp/wget: fix build with texinfo-5 installedvd2013-05-171-0/+40 * - Update to 0.9.10bdrewery2013-05-174-35/+49 * ftp/wget: Add an option for choosing whether to use PCRE or not.vd2013-05-141-12/+13 * ftp/wget: hook a dependency to devel/pcrevd2013-05-131-0/+11 * mark as BROKENoliver2013-05-131-0/+2 * Merge r317659 by ale from ftp/php5-ftp:flo2013-05-101-5/+4 * - Remove leading indefinite article from COMMENTsunpoet2013-05-081-8/+3 * Make ssl support deterministic.ale2013-05-081-0/+4 * - Update to 20130505bdrewery2013-05-072-11/+6 * - Use CERTFILE for custom certificate locationsunpoet2013-05-071-4/+3 * - Fix shebang line for users without USE_PERL=yessunpoet2013-05-071-2/+1 * Convert USE_NCURSES by USES=ncursesbapt2013-05-064-6/+5 * Fix installation of ports that rely on cp -n for installing files. r245960flo2013-05-051-3/+3 * Chase security/libgcrypt updateehaupt2013-05-041-0/+1 * Update to version 4.0.demon2013-04-303-8/+9 * - Update to 0.8.3miwi2013-04-307-116/+167 * - Update to 1.42miwi2013-04-303-37/+33 * Add Gstreamer 1.0.7. This is the new stable version of thekwm2013-04-282-0/+14 * - Update to 0.42culot2013-04-282-3/+3 * - Convert USE_ICONV=yes to USES=iconvmva2013-04-276-8/+6 * Convert from USE_GETTEXT to USES= gettextbapt2013-04-272-19/+13 * - Convert USE_GETTEXT to USES (part 4)ak2013-04-263-4/+3 * - Convert USE_GETTEXT to USES (part 3)ak2013-04-259-9/+9 * - Convert USE_GETTEXT to USES (part 1)ak2013-04-241-2/+1 * Convert to USES=gettextehaupt2013-04-231-1/+1 * Convert f* to USES=pkgconfigbapt2013-04-232-7/+3 * Fix NLS supportpawel2013-04-201-2/+1 * ftp/wget:vd2013-04-182-11/+1 * ftp/wget:vd2013-04-111-2/+2 * - Fix build on amd64ehaupt2013-04-024-9/+26 * - Mark BROKEN fails to buildmiwi2013-04-021-0/+1 * For perl@ owned ports:eadler2013-03-292-2/+2 * Style: tab -> space.eadler2013-03-291-1/+1 * - Update to 20130325miwi2013-03-289-25/+19 * Convert left unconverted ports in ftp to new options frameworkbapt2013-03-267-141/+102 * - Fix build after glib update [1]pawel2013-03-251-5/+9 * - Update to 2.6.2acm2013-03-231-1/+1 * - convert USE_CMAKE to USESmakc2013-03-231-1/+1 * This changes almost all the "gnomehack" only USE_GNOME cases to USES= pathfix.eadler2013-03-192-2/+2 * Fix a long standing bug of lib/charset.alias being overwritten, modified, and...bapt2013-03-181-5/+2 * Update to 4.4.5martymac2013-03-182-3/+3 * Update to version 3.7.2.demon2013-03-182-3/+3 * Correct PORTREVISIONmiwi2013-03-181-1/+1 * - Unbreak buildmiwi2013-03-181-4/+2 * In categories starting with [efg], remove empty lines from pkg-plist (exceptdanfe2013-03-171-1/+0 * - Convert to PEAR_AUTOINSTALLmiwi2013-03-151-14/+2 * - adopt optionsNG and trim historical headersjgh2013-03-141-6/+4 * 2013-03-05 ftp/proma: Broken for more than 6 monthbapt2013-03-106-98/+0 * Fix build with disabled IPv6mm2013-03-092-0/+13 * Remove indefinite article from COMMENTehaupt2013-03-081-1/+1 * - Update to 1.95-4.1tota2013-03-082-4/+3 * Update proftpd to 1.3.4cmm2013-03-073-4/+4 * update math/R to 2.15.3, and adjust dependent portsbf2013-03-071-1/+1 * - Please welcome back Chris Petrik as maintainer ofbdrewery2013-03-074-20/+7 * Update to 4.4.4martymac2013-03-052-3/+3 * Update to 3.6.0.2.jsa2013-03-042-8/+4 * Deorbit expired ftp/ftp-tls and ftp/ftpd-tls.marius2013-03-0318-561/+0 * Convert to new options frameworkbapt2013-02-211-11/+8 * - Reassign ports from avl@ back to pool at his request.fluffy2013-02-211-1/+1 * Upgrade ftp/wget from 1.13.4 to 1.14vd2013-02-192-4/+3 * Horde suite update:mm2013-02-132-3/+3 * Update to 4.4.3martymac2013-02-122-4/+3 * - Support CFLAGS/CXXFLAGS properlymiwi2013-02-081-22/+23 * - Fix breakage in the DYNAMIC-enabled ports triggered by the recentpgj2013-02-061-0/+1 * - Add UPDATING entry for gnutls updatenovel2013-02-066-6/+8 * Mark as deprecated a bunch of ports that are marked as broken for more than 6bapt2013-02-051-0/+2 * - Update to 4.4.2martymac2013-02-043-3/+149 * - Fix all cases of 'No newline at end of file' in ports treeak2013-02-011-1/+1 * Update to 4.4.1martymac2013-02-013-8/+5 * Bump PORTREVISION after DESKTOP_ENTRIES updatemakc2013-01-231-1/+1 * - Update DESKTOP_ENTRIES:makc2013-01-231-4/+4 * Only install the bash completion file if the newly-added BASH option is set.rakuco2013-01-201-5/+11 * - Update to 1.2.4.rakuco2013-01-172-8/+4 * - Use DOC instead of NOPORTDOCSehaupt2013-01-151-6/+6 * Update to 0.38.tobez2013-01-132-8/+4 * Update Horde Groupware to 5.0.3:mm2013-01-112-3/+3 * update the R base ports to 2.15.2 and adjust dependent portsbf2013-01-051-0/+1 * Update to 1.125.tobez2013-01-012-13/+7 * Mark deprecated with an expiration on 2013-01-31. Unfortunately, thesemarius2012-12-302-0/+6 * - Deprecate QT3, KDE3 and unmaintained ports depending on them. QT 3.3.8beat2012-12-304-0/+12 * - Convert to new options frameworkbapt2012-12-301-42/+42 * - Update The Glorious Glasgow Haskell Compiler to version 7.4.2pgj2012-12-203-12/+5 * Horde port fixes:mm2012-12-181-2/+2 * Rename horde4-* apps to horde-*mm2012-12-184-1/+1 * Cleanup supporting perl version 5.8 and 5.10,az2012-12-172-18/+2 * Rename package names for horde3 ports to horde3-*mm2012-12-161-1/+1 * - Support USE_READLINE.araujo2012-12-141-10/+14 * - Support USE_READLINE.araujo2012-12-141-15/+33 * - Support USE_READLINE.araujo2012-12-141-10/+16 * Update horde4 packages and applications to horde5mm2012-12-122-8/+10 * Rename old horde applications to horde3- prefixmm2012-12-126-2/+2 * - Use radio options for SSL flavourmartymac2012-12-121-6/+6 * Use current local time Perl module, timelocal.pl is deprecated.cy2012-12-112-1/+13 * Convert SINGLE -> RADIO optionbapt2012-12-111-5/+4 * Update PCRE to 8.32mm2012-12-111-1/+1 * Decommissioning java 1.5 (EOLed since October 2009):bapt2012-12-101-6/+2 * - update to 3.0.2dinoex2012-12-103-14/+10 * Revert Chris Petrik's ports to the pool. Thank you for all your work so far,...eadler2012-12-103-3/+3 * - Reset MAINTAINER on ports with addresses that have unrecoverable bounces.zi2012-12-071-1/+1 * 2012-11-26 ftp/mget: No more public distfilesbapt2012-11-284-41/+0 * - Update to 1.2.3bdrewery2012-11-282-4/+8 * Updted FileZilla to 3.6.0.1 and convert to OptionsNG format.jsa2012-11-273-21/+114 * Fix build with clang.kevlo2012-11-213-9/+22 * - Update to 1.2.2bdrewery2012-11-103-34/+14 * - Update to 4.4.0martymac2012-11-063-4/+4 * - Update to 1.95-3tota2012-11-052-3/+3 * Deprecate a bunch of ports that are either abandonware and/or for which no morebapt2012-10-261-6/+4 * Update to version 3.7.1.demon2012-10-222-3/+3 * - Add LICENSEsem2012-10-171-24/+28 * - cleanup commentsdinoex2012-10-132-10/+0 * - Update to 1.95-1.1tota2012-10-122-3/+3 * Update to 0.3.9.rakuco2012-10-114-10/+9 * Convert to new options frameworkbapt2012-10-071-4/+5 * - Update to 1.95-0.1tota2012-10-062-3/+3 * Change headers of all ports maintained by me to new formatgarga2012-10-051-5/+1 * - Update to 1.95-0tota2012-10-023-10/+5 * - pass maintainership to new (actually old) volunteerrm2012-09-302-7/+3 * - pass maintainership to new volonteerrm2012-09-303-12/+5 * - new option STACKPROTECTORdinoex2012-09-281-9/+16 * - cleanup linkflagsdinoex2012-09-281-1/+1 * - Fix plist issue with slave curl-hiphop caused by last commitswills2012-09-271-1/+1 * - Tweak USE_PYTHON to -2.7 to match upstream compatibilitylwhsu2012-09-225-35/+99 * - Reassign to the heap at the maintainer's requesttabthorpe2012-09-221-6/+2 * - Install the autoconf file for libcurlswills2012-09-19