aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2006-02-03 00:27:44 +0800
committerglewis <glewis@FreeBSD.org>2006-02-03 00:27:44 +0800
commit8f83446f4ca56727bd1ac17207ff89026762dc93 (patch)
treed144ec422526b94051404d99defa5b18fc5c16c0 /java
parent27cd0040244631f25bea17e2262a9251d1668169 (diff)
downloadfreebsd-ports-gnome-8f83446f4ca56727bd1ac17207ff89026762dc93.tar.gz
freebsd-ports-gnome-8f83446f4ca56727bd1ac17207ff89026762dc93.tar.zst
freebsd-ports-gnome-8f83446f4ca56727bd1ac17207ff89026762dc93.zip
. Enable parallel compilation during the build of HotSpot. Note that we
can't use -j in general since the build of the other bits is almost certainly not -j safe. If set, this will speed up the build for those with an SMP box. [1] . Install the cacerts file from Sun's JDK 1.5.0_06 release rather than using the almost empty one that comes with the SCSL source. [2] . Bump PORTREVISION for the second change. PR: 87552 [1] Submitted by: leafy <leafy@leafy.idv.tw> [1] Prompted by: Panagiotis Astithas <past@ebs.gr> [2]
Diffstat (limited to 'java')
-rw-r--r--java/jdk15/Makefile7
-rw-r--r--java/jdk15/files/cacertsbin0 -> 29731 bytes
-rw-r--r--java/jdk16/Makefile7
-rw-r--r--java/jdk16/files/cacertsbin0 -> 29731 bytes
4 files changed, 12 insertions, 2 deletions
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index f64a3edc4744..90f641b1b346 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jdk
PORTVERSION= ${JDK_VERSION}p${JDK_PATCHSET_VERSION}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= java devel
MASTER_SITES= # http://www.sun.com/software/communitysource/j2se/java2/download.xml
# http://www.eyesbeyond.com/freebsddom/java/jdk15.html
@@ -120,6 +120,9 @@ MAKE_ENV+= ALT_BOOTDIR="${JDK14DIR}" \
.if !defined(WITH_IPV6)
MAKE_ENV+= DONT_ENABLE_IPV6="YES"
.endif
+.if defined(HOTSPOT_BUILD_JOBS)
+MAKE_ENV+= HOTSPOT_BUILD_JOBS=${HOTSPOT_BUILD_JOBS}
+.endif
ALL_TARGET= all
@@ -311,6 +314,8 @@ do-install:
@${FIND} -s ${JDKIMAGEDIR_G} -not -type d | \
${SED} -ne 's#^${JDKIMAGEDIR_G}#jdk${JDK_VERSION}#p' >> ${TMPPLIST}
.endif
+ ${INSTALL_DATA} ${FILESDIR}/cacerts \
+ ${PREFIX}/jdk${JDK_VERSION}/jre/lib/security/cacerts
@${FIND} -s -d ${PREFIX}/jdk${JDK_VERSION} -type d | \
${SED} -ne 's#^${PREFIX}/#@dirrm #p' >> ${TMPPLIST}
@${ECHO_MSG} "@exec ${LOCALBASE}/bin/registervm ${PREFIX}/jdk${JDK_VERSION}/bin/java # FREEBSD-JDK${JDK_VERSION}" >> ${TMPPLIST}
diff --git a/java/jdk15/files/cacerts b/java/jdk15/files/cacerts
new file mode 100644
index 000000000000..dbc3699a9c3a
--- /dev/null
+++ b/java/jdk15/files/cacerts
Binary files differ
diff --git a/java/jdk16/Makefile b/java/jdk16/Makefile
index f64a3edc4744..90f641b1b346 100644
--- a/java/jdk16/Makefile
+++ b/java/jdk16/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jdk
PORTVERSION= ${JDK_VERSION}p${JDK_PATCHSET_VERSION}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= java devel
MASTER_SITES= # http://www.sun.com/software/communitysource/j2se/java2/download.xml
# http://www.eyesbeyond.com/freebsddom/java/jdk15.html
@@ -120,6 +120,9 @@ MAKE_ENV+= ALT_BOOTDIR="${JDK14DIR}" \
.if !defined(WITH_IPV6)
MAKE_ENV+= DONT_ENABLE_IPV6="YES"
.endif
+.if defined(HOTSPOT_BUILD_JOBS)
+MAKE_ENV+= HOTSPOT_BUILD_JOBS=${HOTSPOT_BUILD_JOBS}
+.endif
ALL_TARGET= all
@@ -311,6 +314,8 @@ do-install:
@${FIND} -s ${JDKIMAGEDIR_G} -not -type d | \
${SED} -ne 's#^${JDKIMAGEDIR_G}#jdk${JDK_VERSION}#p' >> ${TMPPLIST}
.endif
+ ${INSTALL_DATA} ${FILESDIR}/cacerts \
+ ${PREFIX}/jdk${JDK_VERSION}/jre/lib/security/cacerts
@${FIND} -s -d ${PREFIX}/jdk${JDK_VERSION} -type d | \
${SED} -ne 's#^${PREFIX}/#@dirrm #p' >> ${TMPPLIST}
@${ECHO_MSG} "@exec ${LOCALBASE}/bin/registervm ${PREFIX}/jdk${JDK_VERSION}/bin/java # FREEBSD-JDK${JDK_VERSION}" >> ${TMPPLIST}
diff --git a/java/jdk16/files/cacerts b/java/jdk16/files/cacerts
new file mode 100644
index 000000000000..dbc3699a9c3a
--- /dev/null
+++ b/java/jdk16/files/cacerts
Binary files differ