aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2016-07-31 20:30:24 +0800
committerbapt <bapt@FreeBSD.org>2016-07-31 20:30:24 +0800
commitc279bd28f94e4f10d8c3f0b05b6612df7a923cb1 (patch)
tree4c7b917c918f851cdc352300b98531deb433e9cd /java
parent2b8a28eee9b5b6b2d80a706e5a22047bfc423081 (diff)
downloadfreebsd-ports-gnome-c279bd28f94e4f10d8c3f0b05b6612df7a923cb1.tar.gz
freebsd-ports-gnome-c279bd28f94e4f10d8c3f0b05b6612df7a923cb1.tar.zst
freebsd-ports-gnome-c279bd28f94e4f10d8c3f0b05b6612df7a923cb1.zip
Remove the deinstall script that appears to be deleting all the temporary files
created by pkg(8) during upgrades It happens because the deinstall script tries to clean up the potential manual VM registration by cleaning out all symlinks to bin/javavm Given all VM are registring/unregistering themselves this part is not needed The other thing the script was doing handling the configuration which has been replaced by @sample. pkg-install has been modified to drop the handling of the configuration file but keep the auto registration if all VM found. While this part is not necessary as well, we keep it because otherwise anyone doing delete/install on javavmwapper version 2.5 being the installed version would end up with all VM unregistered. The pkg-install should be removed after EOL of FreeBSD 10.3 PR: 210313 MFH: 2016Q3
Diffstat (limited to 'java')
-rw-r--r--java/javavmwrapper/Makefile1
-rw-r--r--java/javavmwrapper/files/pkg-install.in11
-rw-r--r--java/javavmwrapper/pkg-plist2
3 files changed, 2 insertions, 12 deletions
diff --git a/java/javavmwrapper/Makefile b/java/javavmwrapper/Makefile
index 32ffaffedc40..260273f48caf 100644
--- a/java/javavmwrapper/Makefile
+++ b/java/javavmwrapper/Makefile
@@ -3,6 +3,7 @@
PORTNAME= javavmwrapper
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= java
MASTER_SITES= # none
DISTFILES= # none
diff --git a/java/javavmwrapper/files/pkg-install.in b/java/javavmwrapper/files/pkg-install.in
index 9e26c5b5ff88..dde5ad143032 100644
--- a/java/javavmwrapper/files/pkg-install.in
+++ b/java/javavmwrapper/files/pkg-install.in
@@ -9,17 +9,6 @@ if [ "x${2}" != "xPOST-INSTALL" ]; then
exit 0
fi
-# The option configuration file
-OPTION_CONF="${PKG_PREFIX}/etc/javavm_opts.conf"
-
-# Install default javavm options configuration
-if [ ! -e "${OPTION_CONF}" ]; then
- cp "${OPTION_CONF}.dist" "${OPTION_CONF}"
-else
- echo "${OPTION_CONF} already exists - not installing."
- echo "You may need to hand merge changes."
-fi
-
# Ensure all JDKs and JREs are installed
_excl_dirs='bootstrap-openjdk'
_find_expr='-depth 2 -regex .*/bin/java'
diff --git a/java/javavmwrapper/pkg-plist b/java/javavmwrapper/pkg-plist
index 03f8a854f67a..e4a7a2caaef1 100644
--- a/java/javavmwrapper/pkg-plist
+++ b/java/javavmwrapper/pkg-plist
@@ -4,7 +4,7 @@ bin/javavm
bin/manvm
bin/registervm
bin/unregistervm
-etc/javavm_opts.conf.dist
+@sample etc/javavm_opts.conf.dist etc/javavm_opts.conf
man/man1/checkvms.1.gz
man/man1/javavm.1.gz
man/man1/manvm.1.gz