aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-17 20:13:58 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-17 20:13:58 +0800
commit9d2f88748db3b92acbe46223d4b7c6a8acb0fd94 (patch)
treeb948905743547f7a02487b86be0c01759c0e639c /java
parent68eb967b0dc8ccd27c7138e209c1430ce9be68ea (diff)
downloadfreebsd-ports-gnome-9d2f88748db3b92acbe46223d4b7c6a8acb0fd94.tar.gz
freebsd-ports-gnome-9d2f88748db3b92acbe46223d4b7c6a8acb0fd94.tar.zst
freebsd-ports-gnome-9d2f88748db3b92acbe46223d4b7c6a8acb0fd94.zip
Stagify.
Approved by: portmgr@
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-ocl/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/java/eclipse-ocl/Makefile b/java/eclipse-ocl/Makefile
index 988e9d6d8b1e..316ae61306aa 100644
--- a/java/eclipse-ocl/Makefile
+++ b/java/eclipse-ocl/Makefile
@@ -24,14 +24,13 @@ USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
-NO_STAGE= yes
do-install:
- @${MKDIR} ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
- @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
- | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${STAGEDIR}${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
+ @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
+ | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
+ | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
.include <bsd.port.mk>