aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2007-10-21 22:57:14 +0800
committerglewis <glewis@FreeBSD.org>2007-10-21 22:57:14 +0800
commit8c16a750afe15d902730066380d4029a277960c1 (patch)
tree2c78b5b1d690812d7756dc7969c25bfda35c84ee /java
parent01dd3273f7cdaa290a5bcb80dfcdef239acadfa7 (diff)
downloadfreebsd-ports-gnome-8c16a750afe15d902730066380d4029a277960c1.tar.gz
freebsd-ports-gnome-8c16a750afe15d902730066380d4029a277960c1.tar.zst
freebsd-ports-gnome-8c16a750afe15d902730066380d4029a277960c1.zip
. Explicitly pull in X dependencies instead of depending on the open-motif
dependency to implicitly pull in the X libraries we need.
Diffstat (limited to 'java')
-rw-r--r--java/jdk15/Makefile1
-rw-r--r--java/jdk16/Makefile1
2 files changed, 2 insertions, 0 deletions
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index 9e3c3e13a7bf..81deaf62ac28 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -124,6 +124,7 @@ LIB_DEPENDS= nspr4.1:$(PORTSDIR)/devel/nspr
ONLY_FOR_ARCHS= i386 amd64
USE_GMAKE= YES
USE_ICONV= YES
+USE_XORG+= x11 xext xi xmu xp xt xtst
RESTRICTED= "Redistribution of pre-compiled binaries is not permitted"
NO_CDROM= "Redistribution of pre-compiled binaries is not permitted"
diff --git a/java/jdk16/Makefile b/java/jdk16/Makefile
index 1ed14ce3eabb..2645be94f528 100644
--- a/java/jdk16/Makefile
+++ b/java/jdk16/Makefile
@@ -123,6 +123,7 @@ USE_GNOME= desktopfileutils
ONLY_FOR_ARCHS= i386 amd64
USE_GMAKE= YES
USE_ICONV= YES
+USE_XORG+= x11 xext xi xtst
RESTRICTED= "Redistribution of pre-compiled binaries is not permitted"
NO_CDROM= "Redistribution of pre-compiled binaries is not permitted"