aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2010-01-21 23:47:16 +0800
committerglewis <glewis@FreeBSD.org>2010-01-21 23:47:16 +0800
commit95ff416bf911a511625b81443b3349de650622c1 (patch)
treef9ac01bc08e5b2173d0ade643ce4faa11fff8b8a /java
parent02ec5859e0208217a541dca4111377a20f5626cd (diff)
downloadfreebsd-ports-gnome-95ff416bf911a511625b81443b3349de650622c1.tar.gz
freebsd-ports-gnome-95ff416bf911a511625b81443b3349de650622c1.tar.zst
freebsd-ports-gnome-95ff416bf911a511625b81443b3349de650622c1.zip
. Install the unlimited strength crypto policy JARs rather than the
limited strength ones. Since unlike many other JDK ports this doesn't require an extra download its currently done for all installs rather than being an option. Note that unlike the officially downloaded policy JARs the ones this installs are not signed. This may mean we revisit it once there is an official JDK7 release. . Bump PORTREVISION for this change. Submitted by: ale@
Diffstat (limited to 'java')
-rw-r--r--java/openjdk7/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/java/openjdk7/Makefile b/java/openjdk7/Makefile
index bc052268fb63..2f58bc89cd47 100644
--- a/java/openjdk7/Makefile
+++ b/java/openjdk7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openjdk
PORTVERSION= ${JDK_MAJOR_VERSION}.${JDK_MINOR_VERSION}.${JDK_BUILD_NUMBER}
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= http://download.java.net/openjdk/jdk7/promoted/b${JDK_BUILD_NUMBER}/ \
${MASTER_SITE_APACHE:S,%SUBDIR%/,ant/binaries/:ant,}
@@ -111,6 +112,10 @@ post-extract:
${SED} -e 's/linux/bsd/g' -e 's/Linux/Bsd/g' -e 's/LINUX/BSD/g' $$file > $$newfile; \
done
+post-patch:
+ @${REINPLACE_CMD} 's|build-policy install-limited|build-policy install-unlimited|' \
+ ${WRKSRC}/jdk/make/javax/crypto/Makefile
+
do-install:
@${MKDIR} ${INSTALLDIR}
@cd ${WRKSRC}/build/${OPENJDK_OSARCH}/j2sdk-image && \