aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2019-07-10 22:40:02 +0800
committertijl <tijl@FreeBSD.org>2019-07-10 22:40:02 +0800
commita5355304cf326f37ee02d92c02941417cf21a10a (patch)
tree9754e52797ffd2ab1caf7b83b3fa360ba5db8a85 /java
parentd109178ea4a61da72c20ffadb5278818be37a9d7 (diff)
downloadfreebsd-ports-gnome-a5355304cf326f37ee02d92c02941417cf21a10a.tar.gz
freebsd-ports-gnome-a5355304cf326f37ee02d92c02941417cf21a10a.tar.zst
freebsd-ports-gnome-a5355304cf326f37ee02d92c02941417cf21a10a.zip
On amd64 adding DEFAULT_VERSIONS+=linux=c6 to /etc/make.conf made Linux
infrastructure ports (linux_base-c6 and linux-c6*) install i386 CentOS 6 packages. Using c6_64 instead of c6 made them install mixed amd64/i386 CentOS 6 packages and allowed Linux application ports to install amd64 binaries when available. The i386-only configuration was only useful for users of x11/nvidia-driver* which didn't provide Linux amd64 emulation until recently. With x11/nvidia-driver* now supporting Linux amd64 there's no longer a need for i386-only Linux on amd64. Let DEFAULT_VERSIONS+=linux=c6 make Linux infrastructure ports install mixed amd64/i386 CentOS 6 packages, like c6_64 before, and remove support for c6_64 as a value. Replace LINUX_ARCH with ARCH everywhere because they are always the same now.
Diffstat (limited to 'java')
-rw-r--r--java/linux-oracle-jre18/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/java/linux-oracle-jre18/Makefile b/java/linux-oracle-jre18/Makefile
index 914fe9342f98..1b83e09a0ba3 100644
--- a/java/linux-oracle-jre18/Makefile
+++ b/java/linux-oracle-jre18/Makefile
@@ -46,7 +46,7 @@ bash_CMD= ${SH}
.include <bsd.port.pre.mk>
-.if ${LINUX_ARCH} == "i386"
+.if ${ARCH} == i386
PLIST_SUB+= JAVA_ARCHLIBDIR="i386" \
I386_ONLY="" \
AMD64_ONLY="@comment "