aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2010-05-04 13:58:31 +0800
committerglewis <glewis@FreeBSD.org>2010-05-04 13:58:31 +0800
commitae5be8d4c764c35f7559393064b4c1322ca82b86 (patch)
tree2cc38ce0a06895ab4bbfb970a64b1ff727485dde /java
parentfbed333469131d3c084e2f416ffb59ccd86201cb (diff)
downloadfreebsd-ports-gnome-ae5be8d4c764c35f7559393064b4c1322ca82b86.tar.gz
freebsd-ports-gnome-ae5be8d4c764c35f7559393064b4c1322ca82b86.tar.zst
freebsd-ports-gnome-ae5be8d4c764c35f7559393064b4c1322ca82b86.zip
. Fix the specifications of MASTER_SITES -- fixes the fetching of the ANT
distribution at least. . Copy the bundles into the plugin directory during install, otherwise the install creates symlinks to the bundles in the actually port's working directory, which it means it stops working after a 'make clean'. Reported by: Ronald Klop <ronald-freebsd8@thuis.klop.ws>
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-devel/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/java/eclipse-devel/Makefile b/java/eclipse-devel/Makefile
index a312b187301c..71d63c5e5ef5 100644
--- a/java/eclipse-devel/Makefile
+++ b/java/eclipse-devel/Makefile
@@ -7,13 +7,14 @@
PORTNAME= eclipse-devel
PORTVERSION= 3.5.2
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= http://download.eclipse.org/technology/linuxtools/eclipse-build/:1 \
http://download.eclipse.org/tools/orbit/downloads/drops/R20090825191606/bundles/:2 \
http://download.eclipse.org/tools/orbit/downloads/drops/S20100308015149/bundles/:3 \
- ${MASTER_SITE_APACHE:S,%SUBDIR%/,ant/binaries/,}:4 \
- ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%/,junit/junit/${JUNIT3_VERSION}/,}:5 \
- ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%/,junit/junit/${JUNIT4_VERSION}/,}:6
+ ${MASTER_SITE_APACHE:S,%SUBDIR%/,ant/binaries/:4,} \
+ ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%/,junit/junit/${JUNIT3_VERSION}/:5,} \
+ ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%/,junit/junit/${JUNIT4_VERSION}/:6,}
DISTFILES= ${ECLIPSE_BUILD_SRCFILE}:1 \
${ECLIPSE_SRCFILE}:1 \
${ANT_SRCFILE}:4 \
@@ -207,6 +208,8 @@ do-install:
${BUILD_WRKSRC}/eclipse.tmp
.endif
@${INSTALL_SCRIPT} ${WRKSRC}/eclipse.tmp ${PREFIX}/bin/${PORTNAME}
+ @cd ${BUILD_WRKSRC}/bundles && \
+ ${COPYTREE_SHARE} . ${PORTDESTDIR}/plugins/
@${PREFIX}/bin/${PORTNAME} -initialize -consolelog
-@update-desktop-database
@(cd ${PREFIX}; ${FIND} -s lib/${PORTNAME} -not -type d) >> ${TMPPLIST}