aboutsummaryrefslogtreecommitdiffstats
path: root/korean/aleefonts-ttf
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-03-22 07:05:19 +0800
committerbapt <bapt@FreeBSD.org>2015-03-22 07:05:19 +0800
commitfe5a7e4bee2fc7a40343278a44de77847b5c91c5 (patch)
treeb9556c9042a9d20d7c71f49869f39f95afc00052 /korean/aleefonts-ttf
parent9167139629893ea7664f3b1cf93141ff1eeb82b4 (diff)
downloadfreebsd-ports-gnome-fe5a7e4bee2fc7a40343278a44de77847b5c91c5.tar.gz
freebsd-ports-gnome-fe5a7e4bee2fc7a40343278a44de77847b5c91c5.tar.zst
freebsd-ports-gnome-fe5a7e4bee2fc7a40343278a44de77847b5c91c5.zip
Make fonts repecting XDG
Xorg is now looking in ${LOCALBASE}/share/fonts by default Xorg now accepts symlinks in etc/X11/fontpath.d (as decribed in Xserver(1)) Large cleanup on lots of font ports All fonts are now properly dynamically generating fonts.dir and fonts.scale instead of sometime overwriting existing ones) All fonts are generating fontconfig's cache Improve consistency in fonts ports
Diffstat (limited to 'korean/aleefonts-ttf')
-rw-r--r--korean/aleefonts-ttf/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/korean/aleefonts-ttf/Makefile b/korean/aleefonts-ttf/Makefile
index be6919081f54..081a1a72be4e 100644
--- a/korean/aleefonts-ttf/Makefile
+++ b/korean/aleefonts-ttf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= aleefonts
PORTVERSION= 12
+PORTREVISION= 1
CATEGORIES= korean x11-fonts
MASTER_SITES= DEBIAN
MASTER_SITE_SUBDIR= pool/main/t/ttf-alee
@@ -15,26 +16,17 @@ COMMENT= A-Lee's Hangul truetype fonts #'
LICENSE= ART10
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${LOCALBASE}/bin/mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
- ${LOCALBASE}/bin/mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
+USES= fonts
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
-FONTSDIR= lib/X11/fonts/alee${PKGNAMESUFFIX}
FONTLIST= Bandal Bangwool Eunjin EunjinNakseo Guseul
-FONTFILES= ${FONTLIST:S/$/.ttf/} fonts.dir fonts.scale
+FONTFILES= ${FONTLIST:S/$/.ttf/}
+NO_BUILD= yes
PLIST_FILES= ${FONTFILES:S|^|${FONTSDIR}/|}
-do-build:
- ${LOCALBASE}/bin/mkfontscale ${WRKSRC}
- ${LOCALBASE}/bin/mkfontdir ${WRKSRC}
-
do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/${FONTSDIR}
- ${INSTALL_DATA} ${FONTFILES:S|^|${WRKSRC}/|} ${STAGEDIR}${PREFIX}/${FONTSDIR}
-
-post-install:
- @${ECHO_CMD} "@exec fc-cache -s %D/${FONTSDIR} 2>/dev/null || true" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec fc-cache -s %D/${FONTSDIR} 2>/dev/null || true" >> ${TMPPLIST}
+ ${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${FONTFILES:S|^|${WRKSRC}/|} ${STAGEDIR}${FONTSDIR}
.include <bsd.port.mk>