aboutsummaryrefslogtreecommitdiffstats
path: root/korean/h2ps
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1997-03-25 18:47:28 +0800
committerobrien <obrien@FreeBSD.org>1997-03-25 18:47:28 +0800
commitacfe592a5413a3bfd181a9f8391a50684fc19380 (patch)
treede9e27ec21970447f6db112e5acab68cd04ac4ac /korean/h2ps
parent089b0e5fd747b145b6794eaf618098cdf5da8847 (diff)
downloadfreebsd-ports-gnome-acfe592a5413a3bfd181a9f8391a50684fc19380.tar.gz
freebsd-ports-gnome-acfe592a5413a3bfd181a9f8391a50684fc19380.tar.zst
freebsd-ports-gnome-acfe592a5413a3bfd181a9f8391a50684fc19380.zip
text-to-postscript filter with Korean fonts.
Submitted by: Choi Jun Ho <junker@jazz.snu.ac.kr> Closes PR: ports/3044
Diffstat (limited to 'korean/h2ps')
-rw-r--r--korean/h2ps/Makefile71
-rw-r--r--korean/h2ps/distinfo1
-rw-r--r--korean/h2ps/files/patch-aa15
-rw-r--r--korean/h2ps/pkg-comment1
-rw-r--r--korean/h2ps/pkg-descr11
-rw-r--r--korean/h2ps/pkg-plist2
6 files changed, 101 insertions, 0 deletions
diff --git a/korean/h2ps/Makefile b/korean/h2ps/Makefile
new file mode 100644
index 000000000000..a5a3c792a454
--- /dev/null
+++ b/korean/h2ps/Makefile
@@ -0,0 +1,71 @@
+# New ports collection makefile for: h2ps-1.0
+# Version required: 1.0
+# Date created: 20 May 1997
+# Whom: Choi Jun Ho <junker@jazz.snu.ac.kr>
+#
+# $Id$
+#
+
+DISTNAME= h2ps-1.0
+PKGNAME= kr-h2ps-${PAPERSIZE}-1.0
+CATEGORIES= korean print
+MASTER_SITES= ftp://cglab.snu.ac.kr/pub/hangul/n3f/applications/
+
+MAINTAINER= junker@jazz.snu.ac.kr
+
+MAKE_FLAGS?= WIDTH=${WIDTH} HEIGHT=${HEIGHT} A4_PAPERSIZE=${A4_PAPERSIZE} -f
+MAN1= h2ps.1
+
+letter::
+ ${MAKE} PAPERSIZE=letter
+
+letter-install::
+ ${MAKE} PAPERSIZE=letter install
+
+a4::
+ ${MAKE} PAPERSIZE=a4
+
+a4-install::
+ ${MAKE} PAPERSIZE=a4 install
+
+
+.if !defined(PAPERSIZE)
+PAPERSIZE=a4
+WIDTH=8.27
+HEIGHT=11.64
+A4_PAPERSIZE=1
+PAPERSIZE_UNSPECIFIED= yes
+.elif ${PAPERSIZE} == A4 || ${PAPERSIZE} == a4
+PAPERSIZE=a4
+WIDTH=8.27
+HEIGHT=11.64
+A4_PAPERSIZE=1
+.elif ${PAPERSIZE} == letter || ${PAPERSIZE} == LETTER
+PAPERSIZE=letter
+WIDTH=8.5
+HEIGHT=11.0
+A4_PAPERSIZE=0
+.else
+PAPERSIZE_INVALID= yes
+.endif # not defined PAPERSIZE
+
+
+pre-fetch:
+.if defined(PAPERSIZE_UNSPECIFIED)
+ @echo "Defaulting to ${PAPERSIZE} sized paper."
+ @echo ""
+ @echo "Set the environment variable PAPERSIZE if you want to use other sizes."
+ @echo "Possible values are: A4 (default) or letter"
+.elif defined(PAPERSIZE_INVALID)
+ @echo "Error: invalid value for PAPERSIZE: \"${PAPERSIZE}\""
+ @echo "Possible values are: A4 (default) or letter"
+ @/usr/bin/false
+.endif
+
+pre-install:
+ @(cd ${WRKSRC}; make install.man)
+
+post-install:
+ strip ${PREFIX}/bin/h2ps
+
+.include <bsd.port.mk>
diff --git a/korean/h2ps/distinfo b/korean/h2ps/distinfo
new file mode 100644
index 000000000000..a2756b79cc2e
--- /dev/null
+++ b/korean/h2ps/distinfo
@@ -0,0 +1 @@
+MD5 (h2ps-1.0.tar.gz) = bfa63e61e7beb35f387c224679e5e7e4
diff --git a/korean/h2ps/files/patch-aa b/korean/h2ps/files/patch-aa
new file mode 100644
index 000000000000..aa2ee6214659
--- /dev/null
+++ b/korean/h2ps/files/patch-aa
@@ -0,0 +1,15 @@
+diff -c -r ../h2ps-1.0-orig/h2ps.1 ./h2ps.1
+*** ../h2ps-1.0-orig/h2ps.1 Wed Mar 19 21:29:14 1997
+--- ./h2ps.1 Wed Mar 19 21:42:46 1997
+***************
+*** 156,161 ****
+--- 156,164 ----
+ is the number of copies desired of each file named. By default, you get
+ only one copy.
+ .TP 0.6i
++ .B -a
++ Use the American paper size (8.5" x 11") as the basis for all calculations.
++ .TP 0.6i
+ .B -d
+ Print the current date and time at the bottom of the page. This option
+ is affected by the no surrounding border and the no header options.
diff --git a/korean/h2ps/pkg-comment b/korean/h2ps/pkg-comment
new file mode 100644
index 000000000000..eee098160907
--- /dev/null
+++ b/korean/h2ps/pkg-comment
@@ -0,0 +1 @@
+Formats an ascii file for printing on a postscript printer with Korean char.
diff --git a/korean/h2ps/pkg-descr b/korean/h2ps/pkg-descr
new file mode 100644
index 000000000000..d61da25a2fb6
--- /dev/null
+++ b/korean/h2ps/pkg-descr
@@ -0,0 +1,11 @@
+h2ps formats each named file for printing in a postscript printer with
+embedded PS hangul fonts; if no file is given, h2ps reads from the
+standard input. The format used is nice and compact: normally two pages
+on each physical page, borders surrounding pages, headers with useful
+information (page number, printing date, file name or supplied header),
+line numbering, etc. This is very useful for making archive listings of
+programs.
+
+It is relatively compat when comparing with nh2ps, and no need to another
+fonts or ghostscript. It can be printed with any PostScript printer only
+with english fonts because its fonts are embedded with output.
diff --git a/korean/h2ps/pkg-plist b/korean/h2ps/pkg-plist
new file mode 100644
index 000000000000..08ac0554c510
--- /dev/null
+++ b/korean/h2ps/pkg-plist
@@ -0,0 +1,2 @@
+bin/h2ps
+man/man1/h2ps.1.gz