aboutsummaryrefslogtreecommitdiffstats
path: root/korean/ibus-hangul
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2011-08-09 06:37:15 +0800
committerjkim <jkim@FreeBSD.org>2011-08-09 06:37:15 +0800
commite009d374184d027b6e127cac0a5615eceb239933 (patch)
tree32f105300fbbf5379d02dfbacf9cfb0dfe3cecd5 /korean/ibus-hangul
parentaef7be01ee6ba69ec557db3f2b7a94a4bfd332db (diff)
downloadfreebsd-ports-gnome-e009d374184d027b6e127cac0a5615eceb239933.tar.gz
freebsd-ports-gnome-e009d374184d027b6e127cac0a5615eceb239933.tar.zst
freebsd-ports-gnome-e009d374184d027b6e127cac0a5615eceb239933.zip
IBus-Hangul is an input method (IM) for Korean language, based on IBus.
WWW: http://code.google.com/p/ibus/
Diffstat (limited to 'korean/ibus-hangul')
-rw-r--r--korean/ibus-hangul/Makefile34
-rw-r--r--korean/ibus-hangul/distinfo2
-rw-r--r--korean/ibus-hangul/files/patch-setup-Makefile.in11
-rw-r--r--korean/ibus-hangul/pkg-descr3
-rw-r--r--korean/ibus-hangul/pkg-message35
-rw-r--r--korean/ibus-hangul/pkg-plist23
6 files changed, 108 insertions, 0 deletions
diff --git a/korean/ibus-hangul/Makefile b/korean/ibus-hangul/Makefile
new file mode 100644
index 000000000000..40e2ec669977
--- /dev/null
+++ b/korean/ibus-hangul/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: ibus-hangul
+# Date created: August 8, 2011
+# Whom: Jung-uk Kim <jkim@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ibus-hangul
+PORTVERSION= 1.3.1
+CATEGORIES= korean
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= jkim@FreeBSD.org
+COMMENT= Hangul input engine for IBus
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= hangul.1:${PORTSDIR}/korean/libhangul
+RUN_DEPENDS= ibus-daemon:${PORTSDIR}/textproc/ibus
+
+PROJECTHOST= ibus
+
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= intltool
+USE_PYTHON= yes
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO} To display this message again, type ${PKG_INFO} -D ${PKGNAME}
+
+.include <bsd.port.mk>
diff --git a/korean/ibus-hangul/distinfo b/korean/ibus-hangul/distinfo
new file mode 100644
index 000000000000..69d603e62c16
--- /dev/null
+++ b/korean/ibus-hangul/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ibus-hangul-1.3.1.tar.gz) = 1e5530c1d7add8970f3a98a76a0a2feda06a08d65af56fbba5329a6645915afc
+SIZE (ibus-hangul-1.3.1.tar.gz) = 431214
diff --git a/korean/ibus-hangul/files/patch-setup-Makefile.in b/korean/ibus-hangul/files/patch-setup-Makefile.in
new file mode 100644
index 000000000000..8ce1a681768b
--- /dev/null
+++ b/korean/ibus-hangul/files/patch-setup-Makefile.in
@@ -0,0 +1,11 @@
+--- setup/Makefile.in.orig 2011-02-26 07:23:07.000000000 -0500
++++ setup/Makefile.in 2011-08-08 17:42:12.000000000 -0400
+@@ -302,7 +302,7 @@
+ libexec_SCRIPTS = ibus-setup-hangul
+ hangul_keyboard_list_SOURCES = hangul_keyboard_list.c
+ hangul_keyboard_list_CFLAGS = $(HANGUL_CFLAGS)
+-hangul_keyboard_list_LDADD = $(HANGUL_LIBS)
++hangul_keyboard_list_LDADD = $(HANGUL_LIBS) $(INTLLIBS)
+ CLEANFILES = \
+ *.pyc \
+ $(NULL)
diff --git a/korean/ibus-hangul/pkg-descr b/korean/ibus-hangul/pkg-descr
new file mode 100644
index 000000000000..db2489b567b8
--- /dev/null
+++ b/korean/ibus-hangul/pkg-descr
@@ -0,0 +1,3 @@
+IBus-Hangul is an input method (IM) for Korean language, based on IBus.
+
+WWW: http://code.google.com/p/ibus/
diff --git a/korean/ibus-hangul/pkg-message b/korean/ibus-hangul/pkg-message
new file mode 100644
index 000000000000..ebdbfcb940f0
--- /dev/null
+++ b/korean/ibus-hangul/pkg-message
@@ -0,0 +1,35 @@
+ibus-hangul installation finished. To use ibus-hangul, please do the following:
+
+If you are using bash or zsh, please add following lines to your $HOME/.bashrc or
+$HOME/.zshrc:
+
+export XIM=ibus
+export GTK_IM_MODULE=ibus
+export QT_IM_MODULE=xim
+export XMODIFIERS=@im=ibus
+export XIM_PROGRAM="ibus-daemon"
+export XIM_ARGS="-r --daemonize --xim"
+
+If you are using tcsh, please add following lines to your $HOME/.cshrc:
+
+setenv XIM ibus
+setenv GTK_IM_MODULE ibus
+setenv QT_IM_MODULE xim
+setenv XMODIFIERS @im=ibus
+setenv XIM_PROGRAM ibus-daemon
+setenv XIM_ARGS "-r --daemonize --xim"
+
+If you are using KDE4, you may create a shell script in $HOME/.kde4/env,
+and add following lines:
+
+#!/bin/sh
+export XIM=ibus
+export GTK_IM_MODULE=ibus
+export QT_IM_MODULE=xim
+export XMODIFIERS=@im=ibus
+export XIM_PROGRAM="ibus-daemon"
+export XIM_ARGS="-r --daemonize --xim"
+
+If ibus cannot start or the panel does not appear, please ensure
+that you are using up-to-date python.
+There's a bug in python 2.5, which may prevent the panel from appearing.
diff --git a/korean/ibus-hangul/pkg-plist b/korean/ibus-hangul/pkg-plist
new file mode 100644
index 000000000000..720b90a84aff
--- /dev/null
+++ b/korean/ibus-hangul/pkg-plist
@@ -0,0 +1,23 @@
+lib/locale/ko/LC_MESSAGES/ibus-hangul.mo
+lib/locale/zh_CN/LC_MESSAGES/ibus-hangul.mo
+libexec/ibus-engine-hangul
+libexec/ibus-setup-hangul
+share/ibus/component/hangul.xml
+%%DATADIR%%/data/symbol.txt
+%%DATADIR%%/icons/ibus-hangul.png
+%%DATADIR%%/icons/ibus-hangul.svg
+%%DATADIR%%/setup/config.py
+%%DATADIR%%/setup/config.pyc
+%%DATADIR%%/setup/config.pyo
+%%DATADIR%%/setup/hangul_keyboard_list
+%%DATADIR%%/setup/keycapturedialog.py
+%%DATADIR%%/setup/keycapturedialog.pyc
+%%DATADIR%%/setup/keycapturedialog.pyo
+%%DATADIR%%/setup/main.py
+%%DATADIR%%/setup/main.pyc
+%%DATADIR%%/setup/main.pyo
+%%DATADIR%%/setup/setup.ui
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/setup
+@dirrm %%DATADIR%%