aboutsummaryrefslogtreecommitdiffstats
path: root/korean
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-01-05 07:27:58 +0800
committerantoine <antoine@FreeBSD.org>2014-01-05 07:27:58 +0800
commit40498420b2ab5001c62d3454c3f4180ef99df04b (patch)
tree5094821d4832268b6a38be61f91d1a9645a988e9 /korean
parent27009bfb716dae775c407ecb6388054f33d9efd1 (diff)
downloadfreebsd-ports-gnome-40498420b2ab5001c62d3454c3f4180ef99df04b.tar.gz
freebsd-ports-gnome-40498420b2ab5001c62d3454c3f4180ef99df04b.tar.zst
freebsd-ports-gnome-40498420b2ab5001c62d3454c3f4180ef99df04b.zip
With gtk 2.4.22, immodule cache has moved from gtk.immodules to
immodules.cache. gtk-query-immodules-2.0 has a new option, --update-cache that does what we want too. Use this new option. While here, add stage support to non slave ports Reviewed by: kwm (immodules part)
Diffstat (limited to 'korean')
-rw-r--r--korean/imhangul/Makefile10
-rw-r--r--korean/imhangul/pkg-plist8
2 files changed, 5 insertions, 13 deletions
diff --git a/korean/imhangul/Makefile b/korean/imhangul/Makefile
index 0cc05909b230..180480c11dc4 100644
--- a/korean/imhangul/Makefile
+++ b/korean/imhangul/Makefile
@@ -15,13 +15,11 @@ LIB_DEPENDS= hangul:${PORTSDIR}/korean/libhangul
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
-USES= pkgconfig
+USES= gmake pkgconfig
OPTIONS_DEFINE= GTK3 NLS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGTK3}
@@ -44,10 +42,4 @@ PLIST_SUB+= NLS=""
PLIST_SUB+= NLS="@comment "
.endif
-.if ${PORT_OPTIONS:MGTK3}
-post-install:
- @${LOCALBASE}/bin/gtk-query-immodules-3.0 > \
- ${LOCALBASE}/lib/gtk-3.0/${GTK3_VERSION}/immodules.cache
-.endif
-
.include <bsd.port.mk>
diff --git a/korean/imhangul/pkg-plist b/korean/imhangul/pkg-plist
index 18524729aa1c..8de6d0674518 100644
--- a/korean/imhangul/pkg-plist
+++ b/korean/imhangul/pkg-plist
@@ -2,9 +2,9 @@ lib/gtk-%%GTKVER%%/immodules/im-hangul.a
lib/gtk-%%GTKVER%%/immodules/im-hangul.la
lib/gtk-%%GTKVER%%/immodules/im-hangul.so
%%GTK2%%%%NLS%%share/locale/ko/LC_MESSAGES/im-hangul.mo
-%%GTK2%%@exec %D/bin/gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules
-%%GTK2%%@unexec %D/bin/gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules
+%%GTK2%%@exec %D/bin/gtk-query-immodules-2.0 --update-cache
+%%GTK2%%@unexec %D/bin/gtk-query-immodules-2.0 --update-cache
%%GTK3%%%%NLS%%share/locale/ko/LC_MESSAGES/im-hangul-3.0.mo
-%%GTK3%%@exec %D/bin/gtk-query-immodules-3.0 > %D/lib/gtk-3.0/%%GTK3_VERSION%%/immodules.cache
-%%GTK3%%@unexec %D/bin/gtk-query-immodules-3.0 > %D/lib/gtk-3.0/%%GTK3_VERSION%%/immodules.cache
+%%GTK3%%@exec %D/bin/gtk-query-immodules-3.0 --update-cache
+%%GTK3%%@unexec %D/bin/gtk-query-immodules-3.0 --update-cache
@dirrmtry lib/gtk-%%GTKVER%%/immodules