aboutsummaryrefslogtreecommitdiffstats
path: root/lang/Makefile
diff options
context:
space:
mode:
authorjkoshy <jkoshy@FreeBSD.org>2006-05-16 09:42:47 +0800
committerjkoshy <jkoshy@FreeBSD.org>2006-05-16 09:42:47 +0800
commit09eb67c1e17a0a52511f74f1a359c3d541e6ef79 (patch)
treed59f616a9ce902e9b7893061cbef3f7f79db10cf /lang/Makefile
parent8f7e2e3b2b9b160b8c5e13eff8e43ca2c10dac4e (diff)
downloadfreebsd-ports-gnome-09eb67c1e17a0a52511f74f1a359c3d541e6ef79.tar.gz
freebsd-ports-gnome-09eb67c1e17a0a52511f74f1a359c3d541e6ef79.tar.zst
freebsd-ports-gnome-09eb67c1e17a0a52511f74f1a359c3d541e6ef79.zip
A new port for TinyCC, a small and fast C compiler.
Tcc's features include: * Small: You can compile and execute C code everywhere, for example on rescue disks (about 100KB for x86 TCC executable, including C preprocessor, C compiler, assembler and linker). * Fast: tcc generates optimized x86 code. No byte code overhead. Compile, assemble and link several times faster than GCC. * Unlimited: Any C dynamic library can be used directly. TCC is heading torward full ISOC99 compliance. TCC can of course compile itself. * Safe: tcc includes an optional memory and bound checker. Bound checked code can be mixed freely with standard code. * Compile and execute C source directly. No linking or assembly necessary. Full C preprocessor and GNU-like assembler included. * C script supported : just add '#!/usr/local/bin/tcc -run' at the first line of your C source, and execute it directly from the command line. * With libtcc, you can use TCC as a backend for dynamic code generation.
Diffstat (limited to 'lang/Makefile')
-rw-r--r--lang/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index f3e07d2505e7..3a1de2fcecd5 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -283,6 +283,7 @@
SUBDIR += swi-pl
SUBDIR += sxm
SUBDIR += t3x
+ SUBDIR += tcc
SUBDIR += tcl-manual
SUBDIR += tcl80
SUBDIR += tcl81-thread