aboutsummaryrefslogtreecommitdiffstats
path: root/lang/Sather/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-10-22 14:12:06 +0800
committerijliao <ijliao@FreeBSD.org>2002-10-22 14:12:06 +0800
commitcff40c1083c3488509943a5a615b07027bbbdaf2 (patch)
tree9dfe35dd16dba954cbf2e40c39dc900914290995 /lang/Sather/Makefile
parent402f473319dd6ff40a5d93416e6b0fb7cbdd76e3 (diff)
downloadfreebsd-ports-gnome-cff40c1083c3488509943a5a615b07027bbbdaf2.tar.gz
freebsd-ports-gnome-cff40c1083c3488509943a5a615b07027bbbdaf2.tar.zst
freebsd-ports-gnome-cff40c1083c3488509943a5a615b07027bbbdaf2.zip
- Fix build
- Add several libraries, utilities and documents PR: 44349 Submitted by: Ports Fury
Diffstat (limited to 'lang/Sather/Makefile')
-rw-r--r--lang/Sather/Makefile93
1 files changed, 74 insertions, 19 deletions
diff --git a/lang/Sather/Makefile b/lang/Sather/Makefile
index b3b0a623797e..714267561e93 100644
--- a/lang/Sather/Makefile
+++ b/lang/Sather/Makefile
@@ -8,37 +8,92 @@
PORTNAME= sather
PORTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= sather
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/lib/libgc.a:${PORTSDIR}/devel/boehm-gc
+LIB_DEPENDS= gc.1:${PORTSDIR}/devel/boehm-gc \
+ tk83.1:${PORTSDIR}/x11-toolkits/tk83
USE_REINPLACE= yes
USE_GMAKE= yes
-ALL_TARGET= full
-MAN1= sacomp.1
+ALL_TARGET= full optional
+MAN1= sabrowse.1 sacomp.1
-pre-configure:
- @${REINPLACE_CMD} \
- -e "s:%%CC%%:${CC}:g ;" \
- -e "s:%%CFLAGS%%:${CFLAGS}:g ;" \
- -e "s:%%LOCALBASE%%:${LOCALBASE}:g ;" \
- -e "s:%%GMAKE%%:${GMAKE}:g ;" \
- ${WRKSRC}/System/Common/CONFIG.proto
+post-extract:
+ @${MKDIR} ${WRKSRC}/System/Platforms/freebsd
+.for file in CONFIG Makefile Platform.module header.h
+ @${CP} -f ${FILESDIR}/freebsd-${file} \
+ ${WRKSRC}/System/Platforms/freebsd/${file}
+.endfor
+
+post-patch:
+.for file in Boot/sacomp.code/Makefile Browser/Web/convert-1.1 \
+ Browser/Web/gen_html_class_index Browser/Web/gen_html_sa_files \
+ Browser/Web/gen_html_shortflat Browser/Web/gen_html_top_level \
+ Browser/Web/gen_mml_sa_files Browser/Web/gen_mml_shortflat \
+ Browser/Web/graph2dot Library/System/unix.sa \
+ System/Common/CONFIG.proto System/Platforms/freebsd/CONFIG \
+ System/Platforms/X/Platform.module debian/bin-wrapper
+ @${REINPLACE_CMD} -e 's|%%VERSION%%|${PORTVERSION}|g ; \
+ s|%%CC%%|${CC}|g ; \
+ s|%%CFLAGS%%|${CFLAGS}|g ; \
+ s|%%GMAKE%%|${GMAKE}|g ; \
+ s|%%PREFIX%%|${PREFIX}|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g ; \
+ s|CONFIG_PLATFORMS|unix|g ; \
+ s|CONFIG_DEFAULT_PLATFORM|freebsd|g ; \
+ s|/usr/bin/tclsh|${LOCALBASE}/bin/tclsh8.3|g' ${WRKSRC}/${file}
+.endfor
+
+post-build:
+.for file in sather-tutorial.texinfo sather-mode.texinfo sather.texinfo
+ cd ${WRKSRC}/Emacs && /usr/bin/makeinfo --no-split ${file}
+.endfor
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/Bin/sacomp ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/Doc/man/man1/sacomp.1 ${PREFIX}/man/man1
- @${MKDIR} ${PREFIX}/share/doc/sather
- ${INSTALL_DATA} ${WRKSRC}/Doc/License ${PREFIX}/share/doc/sather
-.if !defined(NOPORTDOCS)
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/sather
-.for file in Bugs Changes Contributing FAQ programmer-manual.ps
- ${INSTALL_DATA} ${WRKSRC}/Doc/${file} ${PREFIX}/share/doc/sather
+ @${MKDIR} ${PREFIX}/lib/sather/Bin
+.for file in sabrowse sacomp
+ ${INSTALL_PROGRAM} ${WRKSRC}/Bin/${file} ${PREFIX}/lib/sather/Bin
+.endfor
+.for file in PP gen_html saprep
+ ${INSTALL_SCRIPT} ${WRKSRC}/Bin/${file} ${PREFIX}/lib/sather/Bin
.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/debian/bin-wrapper ${PREFIX}/lib/sather/Bin
+.for link in sabrowse sacomp
+ ${LN} -sf ${PREFIX}/lib/sather/Bin/bin-wrapper ${PREFIX}/bin/${link}
+.endfor
+.for obj in Browser Library System/Common System/Debug System/FORBID \
+ System/Platforms/X System/Platforms/dualgui System/Platforms/f77 \
+ System/Platforms/freebsd System/Platforms/gui System/Platforms/tcltk
+ ${TAR} -C ${WRKSRC} -cf - \
+ --exclude "ActiveThreads" --exclude "Brahma" \
+ --exclude "CONFIG.proto" --exclude "Siva" \
+ --exclude "dual_gui_server.code" --exclude "*.bak" \
+ --exclude "*.config" --exclude "*.orig" \
+ --exclude "*Makefile*" ${obj} | \
+ ${TAR} -C ${PREFIX}/lib/sather --unlink -xf -
+ @${CHOWN} -R ${LIBOWN}:${LIBGRP} ${PREFIX}/lib/sather/${obj}
+.endfor
+.for file in sabrowse.1 sacomp.1
+ ${INSTALL_MAN} ${WRKSRC}/Doc/man/man1/${file} ${MANPREFIX}/man/man1
+.endfor
+.for file in sather-mode.info sather-tutorial.info sather.info
+ ${INSTALL_DATA} ${WRKSRC}/Emacs/${file} ${PREFIX}/info
+ @install-info ${PREFIX}/info/${file} ${PREFIX}/info/dir
+.endfor
+.for file in hl319.el sather-lib.el sather-module.el sather.el
+ ${INSTALL_DATA} ${WRKSRC}/Emacs/${file} ${PREFIX}/share/emacs/site-lisp
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${TAR} -C ${WRKSRC}/Doc --exclude '*GPL' --exclude man -cf - . | \
+ ${TAR} -C ${DOCSDIR} --unlink -xf -
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
.endif
.include <bsd.port.mk>