aboutsummaryrefslogtreecommitdiffstats
path: root/lang/Sather/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1996-03-07 21:00:53 +0800
committerasami <asami@FreeBSD.org>1996-03-07 21:00:53 +0800
commita6236fb6d55c3092a63b2ba7218cc1e988f75d2f (patch)
tree13768d0dc4cdc2989bdbe1ca2869527982f9fe9d /lang/Sather/Makefile
parent8c83f415276cf36462265cf96f5473053c67be8c (diff)
downloadfreebsd-ports-gnome-a6236fb6d55c3092a63b2ba7218cc1e988f75d2f.tar.gz
freebsd-ports-gnome-a6236fb6d55c3092a63b2ba7218cc1e988f75d2f.tar.zst
freebsd-ports-gnome-a6236fb6d55c3092a63b2ba7218cc1e988f75d2f.zip
Install additional documents conditional to NOPORTDOCS. Note that
"License" is installed unconditionally.
Diffstat (limited to 'lang/Sather/Makefile')
-rw-r--r--lang/Sather/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/lang/Sather/Makefile b/lang/Sather/Makefile
index 2740a9bbae1b..d3ba1d756307 100644
--- a/lang/Sather/Makefile
+++ b/lang/Sather/Makefile
@@ -1,12 +1,13 @@
# New ports collection makefile for: Sather
-# Version required: 1.0.1
+# Version required: 1.0.5
# Date created: Mon Oct 31 22:04:12 PST 1994
# Whom: hsu
#
-# $Id: Makefile,v 1.9 1995/04/24 11:28:53 asami Exp $
+# $Id: Makefile,v 1.10 1995/11/22 13:12:26 asami Exp $
#
DISTNAME= Sather-1.0.5
+PKGNAME= sather-1.0.5
CATEGORIES+= lang
MASTER_SITES= ftp://ftp.icsi.berkeley.edu/pub/sather/
@@ -15,7 +16,14 @@ ALL_TARGET= testall
do-install:
install -c -m 555 ${WRKSRC}/Compiler/cs ${PREFIX}/bin
- install -c -m 555 ${WRKSRC}/Doc/man/man1/cs.1 ${PREFIX}/man/man1
+ install -c -m 444 ${WRKSRC}/Doc/man/man1/cs.1 ${PREFIX}/man/man1
-gzip -9nf ${PREFIX}/man/man1/cs.1
+ mkdir -p ${PREFIX}/share/doc/sather
+ install -c -m 444 ${WRKSRC}/Doc/License ${PREFIX}/share/doc/sather
+.if !defined(NOPORTDOCS)
+.for file in Bugs Changes Contributing FAQ README manual.ps
+ install -c -m 444 ${WRKSRC}/Doc/${file} ${PREFIX}/share/doc/sather
+.endfor
+.endif
.include <bsd.port.mk>