aboutsummaryrefslogtreecommitdiffstats
path: root/lang/TenDRA
diff options
context:
space:
mode:
authorstefanf <stefanf@FreeBSD.org>2004-12-14 17:02:26 +0800
committerstefanf <stefanf@FreeBSD.org>2004-12-14 17:02:26 +0800
commit8bd53577b7051bf6506ae0c5c1453752003b970a (patch)
tree6a77f2d9bf857178af561bac03dca89420a7939e /lang/TenDRA
parentc0f8ef08446ddcab22dec091b2e055805593a217 (diff)
downloadfreebsd-ports-gnome-8bd53577b7051bf6506ae0c5c1453752003b970a.tar.gz
freebsd-ports-gnome-8bd53577b7051bf6506ae0c5c1453752003b970a.tar.zst
freebsd-ports-gnome-8bd53577b7051bf6506ae0c5c1453752003b970a.zip
Fix pkg-plist on Alpha.
Reported by: kris Approved by: clement
Diffstat (limited to 'lang/TenDRA')
-rw-r--r--lang/TenDRA/Makefile10
-rw-r--r--lang/TenDRA/pkg-plist6
2 files changed, 12 insertions, 4 deletions
diff --git a/lang/TenDRA/Makefile b/lang/TenDRA/Makefile
index e69b3ed7e94c..584d3d691d44 100644
--- a/lang/TenDRA/Makefile
+++ b/lang/TenDRA/Makefile
@@ -27,6 +27,14 @@ MAKE_ARGS= BIN_CC="${CC}"
TENDRA_ARCH= ${ARCH:S/i386/80x86/}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+PLIST_SUB+= ONLY_FOR_I386=""
+.else
+PLIST_SUB+= ONLY_FOR_I386="@comment "
+.endif
+
MAN1= calculus.1 disp.1 lexi.1 pl.1 sid.1 tcc.1 tchk.1 \
tcpplus.1 tdfc2.1 tld.1 tnc.1 tspec.1 \
#${TENDRA_ARCH}.freebsd.trans.1
@@ -46,4 +54,4 @@ do-configure:
post-install:
${RMDIR} ${PREFIX}/lib/TenDRA/lib/machines/tokens
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/TenDRA/pkg-plist b/lang/TenDRA/pkg-plist
index 064b18cbb9e9..368730861b92 100644
--- a/lang/TenDRA/pkg-plist
+++ b/lang/TenDRA/pkg-plist
@@ -27,11 +27,11 @@ lib/TenDRA/bin/tspec
lib/TenDRA/env/16bit
lib/TenDRA/env/32bit
lib/TenDRA/env/Goption
-lib/TenDRA/env/K-P5
+%%ONLY_FOR_I386%%lib/TenDRA/env/K-P5
lib/TenDRA/env/K-PIC
lib/TenDRA/env/K-frame
-lib/TenDRA/env/K-i386
-lib/TenDRA/env/K-i486
+%%ONLY_FOR_I386%%lib/TenDRA/env/K-i386
+%%ONLY_FOR_I386%%lib/TenDRA/env/K-i486
lib/TenDRA/env/K-ieee
lib/TenDRA/env/K-noframe
lib/TenDRA/env/K-noieee