aboutsummaryrefslogtreecommitdiffstats
path: root/lang/afnix
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2006-10-08 02:36:44 +0800
committerjohans <johans@FreeBSD.org>2006-10-08 02:36:44 +0800
commitbc74c6c528d4111f8c527fb253f9713be96d4c4a (patch)
treef7dc522d0bd2b381c5be198efe8da78e63cdac6e /lang/afnix
parent94364ec8c1cc082ae175fc5fd349a299068524e4 (diff)
downloadfreebsd-ports-gnome-bc74c6c528d4111f8c527fb253f9713be96d4c4a.tar.gz
freebsd-ports-gnome-bc74c6c528d4111f8c527fb253f9713be96d4c4a.tar.zst
freebsd-ports-gnome-bc74c6c528d4111f8c527fb253f9713be96d4c4a.zip
- Fix build on FreeBSD 4.x
Reported by: krismail
Diffstat (limited to 'lang/afnix')
-rw-r--r--lang/afnix/Makefile2
-rw-r--r--lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak14
2 files changed, 12 insertions, 4 deletions
diff --git a/lang/afnix/Makefile b/lang/afnix/Makefile
index 990f679ea9ae..c42122b1416b 100644
--- a/lang/afnix/Makefile
+++ b/lang/afnix/Makefile
@@ -42,5 +42,7 @@ post-patch:
@${REINPLACE_CMD} -e '/\.rtf/d' ${WRKSRC}/etc/Makefile
@${REINPLACE_CMD} -e '/^MANDIR/s/SHRDIR/MANPREFIX/' \
${WRKSRC}/cnf/mak/afnix-defs.mak
+ @${REINPLACE_CMD} -e '/uname -r/s/\\\./[.-]/' \
+ ${WRKSRC}/cnf/bin/afnix-guess
.include <bsd.port.post.mk>
diff --git a/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak b/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak
index baaecc60cb34..fbd65ddeb202 100644
--- a/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak
+++ b/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak
@@ -1,5 +1,5 @@
---- cnf/mak/afnix-freebsd.mak.orig Wed Aug 31 21:59:00 2005
-+++ cnf/mak/afnix-freebsd.mak Wed Aug 31 22:00:29 2005
+--- cnf/mak/afnix-freebsd.mak.orig Sat Oct 7 20:11:57 2006
++++ cnf/mak/afnix-freebsd.mak Sat Oct 7 20:14:17 2006
@@ -18,21 +18,21 @@
# - compiler and linker section -
# ----------------------------------------------------------------------------
@@ -27,7 +27,7 @@
DBGDEFINES = -DDEBUG
OPTDEFINES =
STDINCLUDE =
-@@ -75,8 +75,8 @@
+@@ -75,14 +75,11 @@
# adjust for freebsd platform
ifeq ($(PLATNAME),freebsd)
@@ -38,7 +38,13 @@
ARFLAGS = rc
LDFLAGS = -shared
AFXCPPLIBS =
-@@ -93,7 +93,7 @@
+-ifeq ($(LKMODE),soname)
+-LDFLAGS += -Wl,-soname,$(SONAME)
+-endif
+ endif
+
+ # ----------------------------------------------------------------------------
+@@ -93,7 +90,7 @@
# adjust linker flags for freebsd
ifeq ($(PLATNAME),freebsd)