aboutsummaryrefslogtreecommitdiffstats
path: root/lang/afnix
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2007-04-19 20:42:27 +0800
committerjohans <johans@FreeBSD.org>2007-04-19 20:42:27 +0800
commitbf7abbe9edfdc525d8f8f1660b5f0d79b0e10feb (patch)
treeae13c299fccd518157b2d8a88e5cb664de599e3d /lang/afnix
parent812310a525f72ce05439cec0d7eb43e94126f070 (diff)
downloadfreebsd-ports-gnome-bf7abbe9edfdc525d8f8f1660b5f0d79b0e10feb.tar.gz
freebsd-ports-gnome-bf7abbe9edfdc525d8f8f1660b5f0d79b0e10feb.tar.zst
freebsd-ports-gnome-bf7abbe9edfdc525d8f8f1660b5f0d79b0e10feb.zip
- Update to 1.5.0
- Remove patches (now fixed in distribution) - Install extra documention and respect NOPORTDOCS
Diffstat (limited to 'lang/afnix')
-rw-r--r--lang/afnix/Makefile26
-rw-r--r--lang/afnix/distinfo6
-rw-r--r--lang/afnix/files/patch-src_lib_plt_acf_Makefile11
-rw-r--r--lang/afnix/files/patch-src_lib_plt_shl_cclk.cxx13
-rw-r--r--lang/afnix/pkg-plist115
5 files changed, 108 insertions, 63 deletions
diff --git a/lang/afnix/Makefile b/lang/afnix/Makefile
index d61aece993d4..4f8b067a0094 100644
--- a/lang/afnix/Makefile
+++ b/lang/afnix/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= afnix
-PORTVERSION= 1.4.3
+PORTVERSION= 1.5.0
CATEGORIES= lang
MASTER_SITES= http://www.afnix.org/ftp/%SUBDIR%/ \
ftp://ftp.stack.nl/pub/users/johans/afnix/
@@ -26,9 +26,15 @@ CONFIGURE_ARGS= -o --prefix "${PREFIX}" --compiler freebsd
MAKE_ENV= CXX="${CXX}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+PORTDOCS= *
PLIST_SUB= PORTVER=${PORTVERSION:R}
-MAN1= axc.1 axd.1 axi.1 axl.1 axs.1
+MAN1= adp::afnix.1 amd::afnix.1 axc::afnix.1 axd::afnix.1 \
+ axi::afnix.1 axl::afnix.1 axs::afnix.1
+MAN3= gfx::afnix.3 net::afnix.3 nwg::afnix.3 pim::afnix.3 \
+ sio::afnix.3 sps::afnix.3 sys::afnix.3 txt::afnix.3 xml::afnix.3
+MAN4= wax::afnix.4 xpe::afnix.4
+MAN7= eul::afnix.7 vol-0::afnix.7 vol-1::afnix.7 vol-2::afnix.7
.include <bsd.port.pre.mk>
@@ -44,4 +50,20 @@ post-patch:
@${REINPLACE_CMD} -e '/uname -r/s/\\\./[.-]/' \
${WRKSRC}/cnf/bin/afnix-guess
+post-install:
+.ifdef NOPORTDOCS
+# install all manuals, but no other documentation
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} doc
+. for i in prj/amd/doc prj/adp/doc src/mod/xml src/srv/xpe
+ @cd ${WRKSRC}/${i} && ${SETENV} ${MAKE_ENV} ${GMAKE} doc
+. endfor
+. for i in ${MAN1} ${MAN3} ${MAN4} ${MAN7}
+ ${INSTALL_MAN} \
+ ${WRKSRC}/bld/${PORTNAME}-doc-${PORTVERSION:S,.,-,g}/man/$i \
+ ${MANPREFIX}/man/man${i:E}/
+. endfor
+.else
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} instdoc
+.endif
+
.include <bsd.port.post.mk>
diff --git a/lang/afnix/distinfo b/lang/afnix/distinfo
index 12699117a075..d4f3470eafad 100644
--- a/lang/afnix/distinfo
+++ b/lang/afnix/distinfo
@@ -1,3 +1,3 @@
-MD5 (afnix-src-1-4-3.tgz) = c9489a70320b227d0db45722e4eb1eda
-SHA256 (afnix-src-1-4-3.tgz) = 22f54b59d4941389c6e100f5c712e6454c842b0000727eeea8f437c03385d16b
-SIZE (afnix-src-1-4-3.tgz) = 1400821
+MD5 (afnix-src-1-5-0.tgz) = bbc14ab8152ae7ec573057fe0c2f4224
+SHA256 (afnix-src-1-5-0.tgz) = 9d265b3f918301b2abf80e2ace8464d4cd487b5a7b44e14fb08d41793a48b837
+SIZE (afnix-src-1-5-0.tgz) = 1525299
diff --git a/lang/afnix/files/patch-src_lib_plt_acf_Makefile b/lang/afnix/files/patch-src_lib_plt_acf_Makefile
deleted file mode 100644
index 4ef939e84ae3..000000000000
--- a/lang/afnix/files/patch-src_lib_plt_acf_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/lib/plt/acf/Makefile.orig Wed Aug 31 22:36:40 2005
-+++ src/lib/plt/acf/Makefile Wed Aug 31 22:36:40 2005
-@@ -48,7 +48,7 @@
- # build the ccnf generator
-
- ccnf: ccnf.cpp
-- @$(CC) $(CNFDEFINES) -o ccnf ccnf.cpp
-+ @$(CC) $(CXXFLAGS) $(CNFDEFINES) -o ccnf ccnf.cpp
-
- # rule: distri
- # this rule install the acf directory in the distribution
diff --git a/lang/afnix/files/patch-src_lib_plt_shl_cclk.cxx b/lang/afnix/files/patch-src_lib_plt_shl_cclk.cxx
deleted file mode 100644
index ca22d624dbd4..000000000000
--- a/lang/afnix/files/patch-src_lib_plt_shl_cclk.cxx
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/lib/plt/shl/cclk.cxx.orig Fri Jul 14 12:03:50 2006
-+++ src/lib/plt/shl/cclk.cxx Thu Aug 3 13:58:51 2006
-@@ -58,8 +58,8 @@ namespace afnix {
- // initialize local and utc structure
- struct tm utm;
- struct tm ltm;
-- if (gmtime_r (&(tval.tv_sec), &utm) == NULL) return 0;
-- if (localtime_r (&(tval.tv_sec), &ltm) == NULL) return 0;
-+ if (gmtime_r ((time_t *)&(tval.tv_sec), &utm) == NULL) return 0;
-+ if (localtime_r ((time_t *)&(tval.tv_sec), &ltm) == NULL) return 0;
- // compute local time in second
- t_long lts = (ltm.tm_yday * 86400) + (ltm.tm_hour * 3600) +
- (ltm.tm_min * 60) + ltm.tm_sec;
diff --git a/lang/afnix/pkg-plist b/lang/afnix/pkg-plist
index 00fb769fd7d8..78d6e0ac2252 100644
--- a/lang/afnix/pkg-plist
+++ b/lang/afnix/pkg-plist
@@ -65,9 +65,16 @@ include/afnix/net/TcpSocket.hpp
include/afnix/net/UdpClient.hpp
include/afnix/net/UdpServer.hpp
include/afnix/net/UdpSocket.hpp
+include/afnix/nwg/Cookie.hpp
+include/afnix/nwg/HttpProto.hpp
+include/afnix/nwg/HttpReply.hpp
+include/afnix/nwg/HttpRequest.hpp
+include/afnix/nwg/HttpResponse.hpp
include/afnix/nwg/Libnwg.hpp
include/afnix/nwg/Mime.hpp
+include/afnix/nwg/NwgCalls.hpp
include/afnix/nwg/Prednwg.hpp
+include/afnix/nwg/Session.hpp
include/afnix/nwg/Uri.hpp
include/afnix/nwg/UriQuery.hpp
include/afnix/pim/Appointer.hpp
@@ -120,6 +127,7 @@ include/afnix/std/Cons.hpp
include/afnix/std/Cursor.hpp
include/afnix/std/Date.hpp
include/afnix/std/Exception.hpp
+include/afnix/std/Freeable.hpp
include/afnix/std/HashTable.hpp
include/afnix/std/Heap.hpp
include/afnix/std/Input.hpp
@@ -149,6 +157,7 @@ include/afnix/std/Output.hpp
include/afnix/std/OutputFile.hpp
include/afnix/std/OutputString.hpp
include/afnix/std/OutputTerm.hpp
+include/afnix/std/Pathname.hpp
include/afnix/std/Plist.hpp
include/afnix/std/PrintTable.hpp
include/afnix/std/Property.hpp
@@ -176,6 +185,7 @@ include/afnix/std/Thread.hpp
include/afnix/std/Thrmap.hpp
include/afnix/std/Time.hpp
include/afnix/std/Transcoder.hpp
+include/afnix/std/Trie.hpp
include/afnix/std/Unicode.hpp
include/afnix/std/Unimapper.hpp
include/afnix/std/Unitabler.hpp
@@ -186,44 +196,57 @@ include/afnix/sys/Libsys.hpp
include/afnix/sys/Predsys.hpp
include/afnix/sys/SysCalls.hpp
include/afnix/txt/Lexeme.hpp
+include/afnix/txt/Lexicon.hpp
include/afnix/txt/Libtxt.hpp
include/afnix/txt/Literate.hpp
include/afnix/txt/Pattern.hpp
include/afnix/txt/Predtxt.hpp
include/afnix/txt/Scanner.hpp
-include/afnix/txt/Sort.hpp
-include/afnix/wam/Cookie.hpp
-include/afnix/wam/HttpReply.hpp
-include/afnix/wam/Libwam.hpp
-include/afnix/wam/Predwam.hpp
-include/afnix/wam/Session.hpp
-include/afnix/wam/XhtmlBody.hpp
-include/afnix/wam/XhtmlCaption.hpp
-include/afnix/wam/XhtmlCgr.hpp
-include/afnix/wam/XhtmlCol.hpp
-include/afnix/wam/XhtmlDiv.hpp
-include/afnix/wam/XhtmlHead.hpp
-include/afnix/wam/XhtmlHr.hpp
-include/afnix/wam/XhtmlHtml.hpp
-include/afnix/wam/XhtmlImg.hpp
-include/afnix/wam/XhtmlMeta.hpp
-include/afnix/wam/XhtmlPara.hpp
-include/afnix/wam/XhtmlRef.hpp
-include/afnix/wam/XhtmlRoot.hpp
-include/afnix/wam/XhtmlStyle.hpp
-include/afnix/wam/XhtmlTable.hpp
-include/afnix/wam/XhtmlTbody.hpp
-include/afnix/wam/XhtmlTd.hpp
-include/afnix/wam/XhtmlTelem.hpp
-include/afnix/wam/XhtmlTfoot.hpp
-include/afnix/wam/XhtmlTh.hpp
-include/afnix/wam/XhtmlThead.hpp
-include/afnix/wam/XhtmlTitle.hpp
-include/afnix/wam/XhtmlTr.hpp
+include/afnix/txt/TxtCalls.hpp
+include/afnix/txt/TxtUtils.hpp
+include/afnix/txt/Worder.hpp
+include/afnix/wax/Libwax.hpp
+include/afnix/wax/Predwax.hpp
+include/afnix/wax/XhtmlBody.hpp
+include/afnix/wax/XhtmlBr.hpp
+include/afnix/wax/XhtmlCaption.hpp
+include/afnix/wax/XhtmlCgr.hpp
+include/afnix/wax/XhtmlCol.hpp
+include/afnix/wax/XhtmlDiv.hpp
+include/afnix/wax/XhtmlEmph.hpp
+include/afnix/wax/XhtmlHead.hpp
+include/afnix/wax/XhtmlHr.hpp
+include/afnix/wax/XhtmlHtml.hpp
+include/afnix/wax/XhtmlImg.hpp
+include/afnix/wax/XhtmlLi.hpp
+include/afnix/wax/XhtmlLink.hpp
+include/afnix/wax/XhtmlMeta.hpp
+include/afnix/wax/XhtmlMime.hpp
+include/afnix/wax/XhtmlPara.hpp
+include/afnix/wax/XhtmlPre.hpp
+include/afnix/wax/XhtmlRef.hpp
+include/afnix/wax/XhtmlRoot.hpp
+include/afnix/wax/XhtmlScript.hpp
+include/afnix/wax/XhtmlStyle.hpp
+include/afnix/wax/XhtmlTable.hpp
+include/afnix/wax/XhtmlTbody.hpp
+include/afnix/wax/XhtmlTd.hpp
+include/afnix/wax/XhtmlTelem.hpp
+include/afnix/wax/XhtmlTfoot.hpp
+include/afnix/wax/XhtmlTh.hpp
+include/afnix/wax/XhtmlThead.hpp
+include/afnix/wax/XhtmlTitle.hpp
+include/afnix/wax/XhtmlTr.hpp
+include/afnix/wax/XhtmlTxtb.hpp
+include/afnix/wax/XhtmlTxti.hpp
+include/afnix/wax/XhtmlTxtt.hpp
+include/afnix/wax/XhtmlUl.hpp
+include/afnix/wax/XmlMime.hpp
include/afnix/xml/Libxml.hpp
include/afnix/xml/Predxml.hpp
include/afnix/xml/XmlAttlist.hpp
include/afnix/xml/XmlBuffer.hpp
+include/afnix/xml/XmlCalls.hpp
include/afnix/xml/XmlComment.hpp
include/afnix/xml/XmlCref.hpp
include/afnix/xml/XmlData.hpp
@@ -242,10 +265,29 @@ include/afnix/xml/XmlReader.hpp
include/afnix/xml/XmlRef.hpp
include/afnix/xml/XmlRoot.hpp
include/afnix/xml/XmlSection.hpp
-include/afnix/xml/XmlStream.hpp
include/afnix/xml/XmlSystem.hpp
include/afnix/xml/XmlTag.hpp
include/afnix/xml/XmlText.hpp
+include/afnix/xml/XmlTexter.hpp
+include/afnix/xml/Xne.hpp
+include/afnix/xml/XneCond.hpp
+include/afnix/xml/XneTree.hpp
+include/afnix/xml/XsmBuffer.hpp
+include/afnix/xml/XsmDocument.hpp
+include/afnix/xml/XsmNode.hpp
+include/afnix/xml/XsmReader.hpp
+include/afnix/xml/XsoBuffer.hpp
+include/afnix/xml/XsoInfo.hpp
+include/afnix/xml/XsoStream.hpp
+include/afnix/xpe/Libxpe.hpp
+include/afnix/xpe/Predxpe.hpp
+include/afnix/xpe/XmlContent.hpp
+include/afnix/xpe/XmlFeature.hpp
+include/afnix/xpe/XmlInclude.hpp
+include/afnix/xpe/XmlProcessor.hpp
+lib/afnix/afnix-adp.axl
+lib/afnix/afnix-amd.axl
+lib/afnix/afnix-apx.axl
lib/libafnix-eng.a
lib/libafnix-eng.so
lib/libafnix-eng.so.1
@@ -279,12 +321,15 @@ lib/libafnix-sys.so.1
lib/libafnix-txt.a
lib/libafnix-txt.so
lib/libafnix-txt.so.1
-lib/libafnix-wam.a
-lib/libafnix-wam.so
-lib/libafnix-wam.so.1
+lib/libafnix-wax.a
+lib/libafnix-wax.so
+lib/libafnix-wax.so.1
lib/libafnix-xml.a
lib/libafnix-xml.so
lib/libafnix-xml.so.1
+lib/libafnix-xpe.a
+lib/libafnix-xpe.so
+lib/libafnix-xpe.so.1
@dirrm etc/afnix
@dirrm include/afnix/cpy
@dirrm include/afnix/eng
@@ -298,6 +343,8 @@ lib/libafnix-xml.so.1
@dirrm include/afnix/std
@dirrm include/afnix/sys
@dirrm include/afnix/txt
-@dirrm include/afnix/wam
+@dirrm include/afnix/wax
@dirrm include/afnix/xml
+@dirrm include/afnix/xpe
@dirrm include/afnix
+@dirrm lib/afnix