aboutsummaryrefslogtreecommitdiffstats
path: root/lang/aleph/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-03-07 01:50:10 +0800
committerijliao <ijliao@FreeBSD.org>2001-03-07 01:50:10 +0800
commit4d2b262303cb2f9d8063f780665ba4c0326b6fa8 (patch)
tree1b6b8c40e06e50854b69e678a451a00b3f08e057 /lang/aleph/Makefile
parentcc6f2a57d8126ce2359b539745b30ad03693d39f (diff)
downloadfreebsd-ports-gnome-4d2b262303cb2f9d8063f780665ba4c0326b6fa8.tar.gz
freebsd-ports-gnome-4d2b262303cb2f9d8063f780665ba4c0326b6fa8.tar.zst
freebsd-ports-gnome-4d2b262303cb2f9d8063f780665ba4c0326b6fa8.zip
add aleph
Aleph is a multi-threaded functional programming language
Diffstat (limited to 'lang/aleph/Makefile')
-rw-r--r--lang/aleph/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/lang/aleph/Makefile b/lang/aleph/Makefile
new file mode 100644
index 000000000000..faeb92b6d21e
--- /dev/null
+++ b/lang/aleph/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: aleph
+# Date created: Mar 7, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aleph
+PORTVERSION= 0.7.1
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp.aleph-lang.org/pub/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTNAME}-${PORTVERSION:S,.,-,g}
+DISTNAME= ${PORTNAME}-src-${PORTVERSION:S,.,-,g}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+USE_GMAKE= yes
+USE_NEWGCC= yes
+
+INSTALLS_SHLIB= yes
+
+MAN1= aleph.1
+
+do-configure:
+ @(cd ${WRKSRC}; ./cnf/bin/aleph-setup -o)
+
+.include <bsd.port.mk>