aboutsummaryrefslogtreecommitdiffstats
path: root/lang/asis
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-11-10 22:59:13 +0800
committermarino <marino@FreeBSD.org>2013-11-10 22:59:13 +0800
commit7feb9b3eac8944bf82a7680a3a955c9451a20791 (patch)
tree03b77ce15831c927beaf305ce4de2489bb804b87 /lang/asis
parent3d9b482ff30b0fa05aa6fcf8b1f3f07d1792f669 (diff)
downloadfreebsd-ports-gnome-7feb9b3eac8944bf82a7680a3a955c9451a20791.tar.gz
freebsd-ports-gnome-7feb9b3eac8944bf82a7680a3a955c9451a20791.tar.zst
freebsd-ports-gnome-7feb9b3eac8944bf82a7680a3a955c9451a20791.zip
lang/asis: Convert to staging
Diffstat (limited to 'lang/asis')
-rw-r--r--lang/asis/Makefile27
1 files changed, 11 insertions, 16 deletions
diff --git a/lang/asis/Makefile b/lang/asis/Makefile
index 500c429cab16..17a9fdde89a9 100644
--- a/lang/asis/Makefile
+++ b/lang/asis/Makefile
@@ -15,12 +15,9 @@ BUILD_DEPENDS= gnat_util>=2013:${PORTSDIR}/lang/gnat_util \
xmlada>=3.2:${PORTSDIR}/textproc/xmlada
USES= ada gmake
+NO_MTREE= yes
+MAKE_ENV= PROCESSORS=${MAKE_JOBS_NUMBER}
-DESTINY= ${WRKDIR}/destino
-MAKE_ENV= DESTDIR=${DESTINY} \
- PROCESSORS=${MAKE_JOBS_NUMBER}
-
-NO_STAGE= yes
post-extract:
@${REINPLACE_CMD} -e 's|OPSYS|ASISOPSYS|g' \
${WRKSRC}/Makefile \
@@ -31,20 +28,18 @@ post-extract:
do-build:
# This target is recreated because -j cannot be set, but
# MAKE_JOBS_SAFE=yes is needed for PROCESSORS value
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gmake all
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gmake ${MAKE_ARGS} all
post-install:
- ${CP} -pR ${DESTINY}${PREFIX}/ ${PREFIX}/
- @cd ${DESTINY}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
- ${SORT} > ${WRKDIR}/PLIST.all
- @cd ${DESTINY}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | \
+ @cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
+ ${SORT} > ${TMPPLIST}
+ @cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | \
${SORT} -r | ${SED} -e '/lib\/gnat$$/d' -e '/share\/doc$$/d' \
-e '/share\/gps$$/d' -e '/share\/gps\/plug-ins$$/d' \
- -e 's/^/@dirrm /g' >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/lib/gnat 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/doc 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/gps/plug-ins 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/gps 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @${CAT} ${WRKDIR}/PLIST.all >> ${TMPPLIST}
+ -e 's/^/@dirrm /g' >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/lib/gnat 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/doc 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/gps/plug-ins 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/gps 2>/dev/null || true" >> ${TMPPLIST}
.include <bsd.port.mk>