aboutsummaryrefslogtreecommitdiffstats
path: root/lang/atlast
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-20 23:07:07 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-20 23:07:07 +0800
commitac67e9bc6a5ee94e22adfc9b9d7179fda279d0ad (patch)
treeebbce14d69f3c67021ea3463d0d410413d341dde /lang/atlast
parent2927307b2d0857471c0d151bd26a6f8a031c0df1 (diff)
downloadfreebsd-ports-gnome-ac67e9bc6a5ee94e22adfc9b9d7179fda279d0ad.tar.gz
freebsd-ports-gnome-ac67e9bc6a5ee94e22adfc9b9d7179fda279d0ad.tar.zst
freebsd-ports-gnome-ac67e9bc6a5ee94e22adfc9b9d7179fda279d0ad.zip
Support staging
Diffstat (limited to 'lang/atlast')
-rw-r--r--lang/atlast/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/lang/atlast/Makefile b/lang/atlast/Makefile
index 34e9643e4010..2b34e977f253 100644
--- a/lang/atlast/Makefile
+++ b/lang/atlast/Makefile
@@ -14,19 +14,18 @@ PLIST_FILES= bin/${PORTNAME}
PORTDOCS= atlast.html atlast.pdf
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
${REINPLACE_CMD} -e "/^COPTIONS = /s, = .*, = ${CFLAGS}, " \
-e "/^CC = /s,= .*, = ${CC}," \
${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>