aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-07-08 17:17:24 +0800
committervanilla <vanilla@FreeBSD.org>2014-07-08 17:17:24 +0800
commitd3f8f6e7b24e21f85f07f69cb061c49502a7dec1 (patch)
tree856e4a22caa00b15fffc39bcd869b4e4c56f7601 /lang/ats
parentc7aed216b5a964fa1b454f25674cebe1a12d08d1 (diff)
downloadfreebsd-ports-gnome-d3f8f6e7b24e21f85f07f69cb061c49502a7dec1.tar.gz
freebsd-ports-gnome-d3f8f6e7b24e21f85f07f69cb061c49502a7dec1.tar.zst
freebsd-ports-gnome-d3f8f6e7b24e21f85f07f69cb061c49502a7dec1.zip
Stagify.
Diffstat (limited to 'lang/ats')
-rw-r--r--lang/ats/Makefile28
1 files changed, 8 insertions, 20 deletions
diff --git a/lang/ats/Makefile b/lang/ats/Makefile
index 11b7ccfb7492..6f3ee51867a8 100644
--- a/lang/ats/Makefile
+++ b/lang/ats/Makefile
@@ -19,14 +19,14 @@ CFLAGS+= -I${LOCALBASE}/include \
-L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE=yes
-
PORTDOCS= FAQ.txt
PORTEXAMPLES= AUP INTRO KernighanRitchie MISC MULTICORE TEST
-OPTIONS_DEFINE= GMP PCRE
+OPTIONS_DEFINE= GMP PCRE DOCS EXAMPLES
OPTIONS_DEFAULT= GMP PCRE
+GMP_LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
+PCRE_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == amd64
@@ -35,14 +35,6 @@ PLIST_SUB+= LIBDIR="lib64"
PLIST_SUB+= LIBDIR="lib"
.endif
-.if ${PORT_OPTIONS:MGMP}
-LIB_DEPENDS+= gmp:${PORTSDIR}/math/gmp
-.endif
-
-.if ${PORT_OPTIONS:MPCRE}
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
-.endif
-
post-patch:
${SED} -i '' -e 's/gcc/${CC}/' \
${WRKSRC}/ccomp/runtime/GCATS/Makefile \
@@ -63,18 +55,14 @@ post-configure:
.endif
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc && \
- ${COPYTREE_SHARE} "${PORTDOCS}" ${DOCSDIR}
-.endif
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
+ ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/doc/EXAMPLE && \
- ${COPYTREE_SHARE} "${PORTEXAMPLES}" ${EXAMPLESDIR}
- ${FIND} ${EXAMPLESDIR} -name Makefile \
+ ${COPYTREE_SHARE} "${PORTEXAMPLES}" ${STAGEDIR}${EXAMPLESDIR}
+ ${FIND} ${STAGEDIR}${EXAMPLESDIR} -name Makefile \
-exec ${SED} -i '' -e 's|^ATSUSRQ=.*|ATSUSRQ="${PREFIX}"|' {} \;
-.endif
.include "bsd.ats.mk"
.include <bsd.port.post.mk>