aboutsummaryrefslogtreecommitdiffstats
path: root/lang/bf2c
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-27 15:16:27 +0800
committeredwin <edwin@FreeBSD.org>2003-09-27 15:16:27 +0800
commitf60eb1b631880e46a05e81177e05c66c53cfcc4d (patch)
tree22a2686bf32500aea36ec0737896087cf2779088 /lang/bf2c
parent0f151023c8710b61926e84864f17f7bb3c36e10f (diff)
downloadfreebsd-ports-gnome-f60eb1b631880e46a05e81177e05c66c53cfcc4d.tar.gz
freebsd-ports-gnome-f60eb1b631880e46a05e81177e05c66c53cfcc4d.tar.zst
freebsd-ports-gnome-f60eb1b631880e46a05e81177e05c66c53cfcc4d.zip
New port: optimizing BF to C compiler
BrainF*ck is a minimalistic, yet Turing-complete programming language with only 8 instructions. bf2c compiles a BF file into a corresponding C file, optimizing as much as possible for speed, size and readability. It is written for fun, self-educating purposes and to beat existing BF compilers. PR: ports/57241 Submitted by: Rene Ladan <r.c.ladan@student.tue.nl>
Diffstat (limited to 'lang/bf2c')
-rw-r--r--lang/bf2c/Makefile29
-rw-r--r--lang/bf2c/distinfo1
-rw-r--r--lang/bf2c/pkg-descr11
-rw-r--r--lang/bf2c/pkg-plist4
4 files changed, 45 insertions, 0 deletions
diff --git a/lang/bf2c/Makefile b/lang/bf2c/Makefile
new file mode 100644
index 000000000000..ba6bedae3b4e
--- /dev/null
+++ b/lang/bf2c/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: bf2c
+# Date created: 4 Sep 2003
+# Whom: r.c.ladan@student.tue.nl
+#
+# $FreeBSD$
+#
+
+PORTNAME= bf2c
+PORTVERSION= 1.2.2
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=bf2c
+
+MAINTAINER= r.c.ladan@student.tue.nl
+COMMENT= Optimizing BrainF*ck to C compiler
+
+USE_GMAKE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bf2c ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/bf2c/distinfo b/lang/bf2c/distinfo
new file mode 100644
index 000000000000..4c9bd42a6338
--- /dev/null
+++ b/lang/bf2c/distinfo
@@ -0,0 +1 @@
+MD5 (bf2c-1.2.2.tar.gz) = c0685f890ff7456d79171af20afdb0c4
diff --git a/lang/bf2c/pkg-descr b/lang/bf2c/pkg-descr
new file mode 100644
index 000000000000..43e8452712fc
--- /dev/null
+++ b/lang/bf2c/pkg-descr
@@ -0,0 +1,11 @@
+BrainF*ck is a minimalistic, yet Turing-complete programming language with
+only 8 instructions. bf2c compiles a BF file into a corresponding C file,
+optimizing as much as possible for speed, size and readability.
+
+It is written for fun, self-educating purposes and to beat existing
+BF compilers.
+
+WWW: http://bf2c.sourceforge.net/
+
+- Rene
+r.c.ladan@student.tue.nl
diff --git a/lang/bf2c/pkg-plist b/lang/bf2c/pkg-plist
new file mode 100644
index 000000000000..257b82faaf64
--- /dev/null
+++ b/lang/bf2c/pkg-plist
@@ -0,0 +1,4 @@
+bin/bf2c
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%