aboutsummaryrefslogtreecommitdiffstats
path: root/lang/bwbasic/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-08-09 22:42:50 +0800
committerasami <asami@FreeBSD.org>1995-08-09 22:42:50 +0800
commitcc5c677b05f8192c506fdd1d39e02cff5424be3d (patch)
treee63c0274789a0632305cb069ed5b4f05f8e10a10 /lang/bwbasic/Makefile
parent11830d9b4929f2b9e469a54c314bf20adefc1305 (diff)
downloadfreebsd-ports-gnome-cc5c677b05f8192c506fdd1d39e02cff5424be3d.tar.gz
freebsd-ports-gnome-cc5c677b05f8192c506fdd1d39e02cff5424be3d.tar.zst
freebsd-ports-gnome-cc5c677b05f8192c506fdd1d39e02cff5424be3d.zip
The Bywater Basic interpreter. If you don't know what Basic is,
you are probably too young to use FreeBSD. :p Submitted by: Michael Smith <msmith@atrad.adelaide.edu.au>
Diffstat (limited to 'lang/bwbasic/Makefile')
-rw-r--r--lang/bwbasic/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/lang/bwbasic/Makefile b/lang/bwbasic/Makefile
new file mode 100644
index 000000000000..c5fd6730ed53
--- /dev/null
+++ b/lang/bwbasic/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: bwbasic
+# Version required: 2.10
+# Date created: 9 Aug 1995
+# Whom: msmith@atrad.adelaide.edu.au
+#
+# $Id$
+#
+
+DISTNAME= bwbasic-2.10
+CATEGORIES+= lang
+MASTER_SITES= ftp://ftp.eng.umd.edu/pub/basic/
+
+MAINTAINER= msmith@atrad.adelaide.edu.au
+
+HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+
+# This puts the documentation in ${PREFIX}/share/bwbasic, and the
+# test programs in ${PREFIX}/share/bwbasic/bwbtest.
+
+post-install:
+ -mkdir ${PREFIX}/share/bwbasic
+ cp ${WRKSRC}/bwbasic.doc ${PREFIX}/share/bwbasic/
+ cp -r ${WRKSRC}/bwbtest ${PREFIX}/share/bwbasic/
+
+.include <bsd.port.mk>