aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ccl
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2010-01-09 22:09:13 +0800
committerolgeni <olgeni@FreeBSD.org>2010-01-09 22:09:13 +0800
commitdfbc178cd555185decbbf2e7e63bc22813759ff0 (patch)
treec8e8dcfac6dd14d638b93b0cfa1a38a8b3f6afa0 /lang/ccl
parentf3277d52bd5490d08926b44837bdaa30beb8440c (diff)
downloadfreebsd-ports-gnome-dfbc178cd555185decbbf2e7e63bc22813759ff0.tar.gz
freebsd-ports-gnome-dfbc178cd555185decbbf2e7e63bc22813759ff0.tar.zst
freebsd-ports-gnome-dfbc178cd555185decbbf2e7e63bc22813759ff0.zip
Integrate adsf-install and the local FreeBSD registry into
asdf:*central-registry* by default.
Diffstat (limited to 'lang/ccl')
-rw-r--r--lang/ccl/Makefile2
-rw-r--r--lang/ccl/files/patch-tools_asdf.lisp16
-rw-r--r--lang/ccl/pkg-message1
3 files changed, 18 insertions, 1 deletions
diff --git a/lang/ccl/Makefile b/lang/ccl/Makefile
index ca56d1a41814..ff8c644a8c63 100644
--- a/lang/ccl/Makefile
+++ b/lang/ccl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ccl
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= lang lisp
MASTER_SITES= ftp://ftp.clozure.com/pub/release/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsdx86
@@ -39,6 +40,7 @@ SUB_LIST+= FX86CL="${FX86CL}" CCL_DIRECTORY="${CCL_DIRECTORY}"
SUB_FILES= ccl.sh
post-patch:
+ @${SED} -i '' -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/tools/asdf.lisp
@${FIND} ${WRKSRC} -name .svn -or -name .cvsignore | ${XARGS} ${RM} -r -f
do-build:
diff --git a/lang/ccl/files/patch-tools_asdf.lisp b/lang/ccl/files/patch-tools_asdf.lisp
new file mode 100644
index 000000000000..da4a17561d17
--- /dev/null
+++ b/lang/ccl/files/patch-tools_asdf.lisp
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- tools/asdf.lisp.orig
++++ tools/asdf.lisp
+@@ -564,7 +564,9 @@
+ (system-source-file (cdr system-pair)))))))
+
+ (defvar *central-registry*
+- `((directory-namestring *default-pathname-defaults*))
++ `((directory-namestring *default-pathname-defaults*)
++ "ccl:tools;asdf-install;"
++ "%%LOCALBASE%%/lib/common-lisp/system-registry/")
+ "A list of 'system directory designators' ASDF uses to find systems.
+
+ A 'system directory designator' is a pathname or a function
diff --git a/lang/ccl/pkg-message b/lang/ccl/pkg-message
index 78a61faad908..2013595fc876 100644
--- a/lang/ccl/pkg-message
+++ b/lang/ccl/pkg-message
@@ -3,7 +3,6 @@ You can permanently enable ASDF package management by using the
following commands in your .ccl-init.lisp file:
(require 'asdf)
- (push "ccl:tools;asdf-install;" asdf:*central-registry*)
(asdf:operate 'asdf:load-op 'asdf-install)
If you wish to disable signature verification (not recommended)