aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ccscript
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-10-14 20:05:42 +0800
committervs <vs@FreeBSD.org>2005-10-14 20:05:42 +0800
commitb7469294e16e9729a3f91c9d60eeb97bffff7345 (patch)
tree4d50a6563c93fb5f3de1493d2751961f36dd4559 /lang/ccscript
parent219cee8312ad79934aaf8a05f2139964a1ac2d89 (diff)
downloadfreebsd-ports-gnome-b7469294e16e9729a3f91c9d60eeb97bffff7345.tar.gz
freebsd-ports-gnome-b7469294e16e9729a3f91c9d60eeb97bffff7345.tar.zst
freebsd-ports-gnome-b7469294e16e9729a3f91c9d60eeb97bffff7345.zip
Fix breakage of ccscript on 4.x by lifting requisite commoncpp to gcc 3.4
(and track this for ccaudio which also uses commoncpp)
Diffstat (limited to 'lang/ccscript')
-rw-r--r--lang/ccscript/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/lang/ccscript/Makefile b/lang/ccscript/Makefile
index 21d50e0c359f..53713abbeb9c 100644
--- a/lang/ccscript/Makefile
+++ b/lang/ccscript/Makefile
@@ -18,7 +18,8 @@ COMMENT= State-event driven class extendible C++ script interpreter
LIB_DEPENDS= ccgnu2-1.3.1:${PORTSDIR}/devel/commoncpp
USE_GNOME= gnometarget
-USE_LIBTOOL_VER= 15
+USE_INC_LIBTOOL_VER= 15
+USE_GCC= 3.4
INSTALL_TARGET= install man
INSTALLS_SHLIB= yes
@@ -32,4 +33,7 @@ MAN3= ScriptCommand.3cc ScriptImage.3cc ScriptInterp.3cc \
CFLAGS+= -fPIC
.endif
+pre-configure:
+ @${CP} ${LTMAIN} ${WRKSRC}/config
+
.include <bsd.port.post.mk>