aboutsummaryrefslogtreecommitdiffstats
path: root/lang/cduce
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2011-04-12 06:37:45 +0800
committerjohans <johans@FreeBSD.org>2011-04-12 06:37:45 +0800
commite13400f7aa3d13c15f308be15f2bcbfec9a949a9 (patch)
treea54db01de5c45503bb1f83378ca2700e38df944e /lang/cduce
parent301bfed2a529b7536504eec371203ed18b416c25 (diff)
downloadfreebsd-ports-gnome-e13400f7aa3d13c15f308be15f2bcbfec9a949a9.tar.gz
freebsd-ports-gnome-e13400f7aa3d13c15f308be15f2bcbfec9a949a9.tar.zst
freebsd-ports-gnome-e13400f7aa3d13c15f308be15f2bcbfec9a949a9.zip
- Fix cduce to work with new ocaml-net version
- Don't build CGI, as netcgi1 is no longer supported and cduce doesn't work with netcgi2 - Bump PORTREVISION Reported by: pointyhat via pav
Diffstat (limited to 'lang/cduce')
-rw-r--r--lang/cduce/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/lang/cduce/Makefile b/lang/cduce/Makefile
index 17f9e267b1be..379551fb45f0 100644
--- a/lang/cduce/Makefile
+++ b/lang/cduce/Makefile
@@ -6,7 +6,7 @@
PORTNAME= cduce
PORTVERSION= 0.5.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://www.cduce.org/download/ \
ftp://ftp.stack.nl/pub/users/johans/cduce/
@@ -31,12 +31,12 @@ USE_GMAKE= yes
ALL_TARGET= all
INSTALL_TARGET= install_bin install_lib
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --with-ocamlopt --with-cgi --without-netclient --without-pxp_wlex --docdir=${DOCSDIR}
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-ocamlopt --without-cgi --without-netclient --without-pxp_wlex --docdir=${DOCSDIR}
SITELIBDIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
MAN1= cduce.1 cduce_mktop.1 dtd2cduce.1
-PLIST_FILES= bin/cduce bin/dtd2cduce
+PLIST_FILES= bin/cduce
.include <bsd.port.pre.mk>
@@ -73,6 +73,10 @@ INSTALL_TARGET+= install_doc
PORTDOCS= *
.endif
+post-patch:
+ ${REINPLACE_CMD} 's/-linkpkg/& -thread/' \
+ ${WRKSRC}/Makefile ${WRKSRC}/configure.ml
+
post-install:
.if defined(WITH_OCAML_EXPAT)
@${ECHO_CMD} "****************************************************************"