aboutsummaryrefslogtreecommitdiffstats
path: root/lang/cduce
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2008-06-10 21:31:25 +0800
committerjohans <johans@FreeBSD.org>2008-06-10 21:31:25 +0800
commitd0d1f71c6055cf3df78ffd6606183732ba1947fd (patch)
treee2fd5d07ee05724678c24535d29d76c4d17a6067 /lang/cduce
parent9b90017c47cc3001c7ba223e112ada39f2c65a1a (diff)
downloadfreebsd-ports-gnome-d0d1f71c6055cf3df78ffd6606183732ba1947fd.tar.gz
freebsd-ports-gnome-d0d1f71c6055cf3df78ffd6606183732ba1947fd.tar.zst
freebsd-ports-gnome-d0d1f71c6055cf3df78ffd6606183732ba1947fd.zip
- Fix NOPORTDOCS logic
Reported by: itetcu
Diffstat (limited to 'lang/cduce')
-rw-r--r--lang/cduce/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/lang/cduce/Makefile b/lang/cduce/Makefile
index af071c9c0221..9d4f50d30c3a 100644
--- a/lang/cduce/Makefile
+++ b/lang/cduce/Makefile
@@ -6,6 +6,7 @@
PORTNAME= cduce
PORTVERSION= 0.5.2.1
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://www.cduce.org/download/ \
ftp://ftp.stack.nl/pub/users/johans/cduce/
@@ -28,9 +29,9 @@ OPTIONS= OCURL "Enable url support via ftp/ocaml-ocurl" Off \
USE_GMAKE= yes
ALL_TARGET= all
-INSTALL_TARGET= install
+INSTALL_TARGET= install_bin install_lib
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --with-ocamlopt --with-cgi --without-netclient --without-pxp_wlex
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-ocamlopt --with-cgi --without-netclient --without-pxp_wlex --docdir=${DOCSDIR}
SITELIBDIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
WRKSRC= ${WRKDIR}/${DISTNAME:R}
@@ -68,7 +69,6 @@ CONFIGURE_ARGS+= --mliface=`cd ${PORTSDIR}/lang/ocaml; ${MAKE} -V WRKSRC`
.endif
.if !defined(NOPORTDOCS)
-CONFIGURE_ARGS+= --docdir=${PREFIX}/share/doc/${PORTNAME}
ALL_TARGET+= doc
INSTALL_TARGET+= install_doc
PORTDOCS= *
@@ -81,5 +81,10 @@ post-install:
@${ECHO_CMD} "* when loading XML files with external DTD. *"
@${ECHO_CMD} "****************************************************************"
.endif
+.if defined(NOPORTDOCS)
+. for i in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${i} ${MANPREFIX}/man/man${i:E}/
+. endfor
+.endif
.include <bsd.port.post.mk>