aboutsummaryrefslogtreecommitdiffstats
path: root/lang/chameleon/Makefile
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2003-04-27 04:09:50 +0800
committerobraun <obraun@FreeBSD.org>2003-04-27 04:09:50 +0800
commit9d6a1f81e8807f14e25a6b1091fe95076bcbfc64 (patch)
treec1c69ed744b8b680664c5596c0b1b9423269b1ff /lang/chameleon/Makefile
parent6fc6f3ac4b6ebf17746818f1dae6de44373eaeb4 (diff)
downloadfreebsd-ports-gnome-9d6a1f81e8807f14e25a6b1091fe95076bcbfc64.tar.gz
freebsd-ports-gnome-9d6a1f81e8807f14e25a6b1091fe95076bcbfc64.tar.zst
freebsd-ports-gnome-9d6a1f81e8807f14e25a6b1091fe95076bcbfc64.zip
Chameleon is a Haskell-style language which allows for type programming via
Constraint Handling Rules (CHRs). Chameleon implements the ideas described in ``A Theory of Overloading''. WWW: http://www.comp.nus.edu.sg/~sulzmann/chameleon/
Diffstat (limited to 'lang/chameleon/Makefile')
-rw-r--r--lang/chameleon/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/lang/chameleon/Makefile b/lang/chameleon/Makefile
new file mode 100644
index 000000000000..34f3b1f8daa4
--- /dev/null
+++ b/lang/chameleon/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: chameleon
+# Date created: 26 April 2003
+# Whom: Oliver Braun <obraun@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= chameleon
+PORTVERSION= 03.04
+CATEGORIES= lang
+MASTER_SITES= http://www.comp.nus.edu.sg/~sulzmann/chameleon/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/./-/}
+
+MAINTAINER= obraun@FreeBSD.org
+COMMENT= A Haskell-style language
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ happy:${PORTSDIR}/devel/hs-happy
+
+ALL_TARGET= just-boo
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/chameleon ${PREFIX}/bin
+ @${MKDIR} ${EXAMPLESDIR}
+ @${FIND} ${WRKSRC}/samples -type f -exec \
+ ${INSTALL_DATA} {} ${EXAMPLESDIR} \;
+
+.include <bsd.port.mk>