aboutsummaryrefslogtreecommitdiffstats
path: root/lang/clang34/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-05-19 22:18:31 +0800
committermarino <marino@FreeBSD.org>2015-05-19 22:18:31 +0800
commit823dde0a096dd464aa02968ea0636bf7bdc8335e (patch)
treed09eada60e0c3706fd611f4e65a9036ed4ec07c4 /lang/clang34/Makefile
parent9be800169c4d78a9267d8d581f50f65121b0adc6 (diff)
downloadfreebsd-ports-gnome-823dde0a096dd464aa02968ea0636bf7bdc8335e.tar.gz
freebsd-ports-gnome-823dde0a096dd464aa02968ea0636bf7bdc8335e.tar.zst
freebsd-ports-gnome-823dde0a096dd464aa02968ea0636bf7bdc8335e.zip
lang/clang3*, lang/clang-devel: set environment during build
The clang ports override the default build target, but the new targets fail to set the environment like the default target does. This patch passes MAKE_ENV to environment. It also combines compounds to a single make cmd and unsuppresses the commands so the output shows on the build logs. PR: 199500 Submitted by: marino Approved by: brooks (maintainer)
Diffstat (limited to 'lang/clang34/Makefile')
-rw-r--r--lang/clang34/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/lang/clang34/Makefile b/lang/clang34/Makefile
index 0ca410af3249..14f0fb084636 100644
--- a/lang/clang34/Makefile
+++ b/lang/clang34/Makefile
@@ -123,11 +123,13 @@ pre-build:
${LN} -sf ${LLVM_PREFIX}/lib/${LIBNAME} ${WRKSRC}/${RELTYPE}/lib/
${LN} -sf ${LLVM_PREFIX}/lib/libLLVMTableGen.a ${WRKSRC}/${RELTYPE}/lib/
${LN} -sf ${LLVM_PREFIX}/lib/libLLVMSupport.a ${WRKSRC}/${RELTYPE}/lib/
- cd ${WRKSRC}/utils/unittest && ${MAKE_CMD}
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${WRKSRC}/utils/unittest
post-build:
- @cd ${WRKSRC}/tools/clang/docs/tools && ${MAKE_CMD} man
- @cd ${WRKSRC}/tools/clang/docs/tools && ${MAKE_CMD} html ps
+ ${SETENV} ${MAKE_ENV} \
+ ${MAKE_CMD} -C ${WRKSRC}/tools/clang/docs/tools man
+ ${SETENV} ${MAKE_ENV} \
+ ${MAKE_CMD} -C ${WRKSRC}/tools/clang/docs/tools html ps
post-install:
${STRIP_CMD} ${STAGEDIR}${LLVM_PREFIX}/lib/libclang.so