aboutsummaryrefslogtreecommitdiffstats
path: root/lang/clisp/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-09-01 13:38:28 +0800
committerknu <knu@FreeBSD.org>2001-09-01 13:38:28 +0800
commit0a1b20794871bb33fc2a7e51973226d98f36d3f1 (patch)
treed0c2b2300315681f7e3fbda7a0f6c67e46f35631 /lang/clisp/Makefile
parent245c7e40a1d5e5e81fee2cfc3074501350b09ad3 (diff)
downloadfreebsd-ports-gnome-0a1b20794871bb33fc2a7e51973226d98f36d3f1.tar.gz
freebsd-ports-gnome-0a1b20794871bb33fc2a7e51973226d98f36d3f1.tar.zst
freebsd-ports-gnome-0a1b20794871bb33fc2a7e51973226d98f36d3f1.zip
Update to 2.27.
PR: ports/30138 Submitted by: Jeff Brown <jabrown@ipn.caida.org> (MAINTAINER) Since both of the two master sites were unreachable, I added MASTER_SITE_SOURCEFORGE to the MASTER_SITES, which sites had the distfile fortunately.
Diffstat (limited to 'lang/clisp/Makefile')
-rw-r--r--lang/clisp/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/lang/clisp/Makefile b/lang/clisp/Makefile
index 0a0641b77fef..145154562844 100644
--- a/lang/clisp/Makefile
+++ b/lang/clisp/Makefile
@@ -6,10 +6,12 @@
#
PORTNAME= clisp
-PORTVERSION= 2.25.1
+PORTVERSION= 2.27
CATEGORIES= lang
-MASTER_SITES= ftp://clisp.cons.org/pub/lisp/clisp/source/
-DISTNAME= ${PORTNAME}-${PORTVERSION}
+MASTER_SITES= ftp://clisp.cons.org/pub/clisp/${PORTVERSION}/ \
+ ftp://clisp.sourceforge.net/pub/clisp/${PORTVERSION}/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jabrown@caida.org
@@ -26,7 +28,7 @@ CONFIGURE_ENV+= INSTALL=${CP} INSTALL_DATA=${CP} INSTALL_PROGRAM=${CP} \
# Build subdirectory
BUILD_DIRNAME=${CONFIGURE_TARGET}
-# These came from clisp-2.25.1's "configure" on my 4.1.1-R system.
+# These came from clisp-2.27's "configure" on my 4.1.1-R system.
MAKEMAKE_ARGS=--prefix=${PREFIX} --with-readline --with-gettext \
--with-dynamic-ffi
@@ -52,7 +54,7 @@ post-extract:
# The 'configure' script stops short of doing this for us.
post-configure:
- @cd ${WRKSRC}/${BUILD_DIRNAME} && \
+ cd ${WRKSRC}/${BUILD_DIRNAME} && \
./makemake ${MAKEMAKE_ARGS} > Makefile && \
make config.lisp