aboutsummaryrefslogtreecommitdiffstats
path: root/lang/cmucl/Makefile
diff options
context:
space:
mode:
authorcracauer <cracauer@FreeBSD.org>1997-07-15 22:35:20 +0800
committercracauer <cracauer@FreeBSD.org>1997-07-15 22:35:20 +0800
commitc9f686c17dfbd8f9fdda127bb537100972d938ae (patch)
tree6062f86a738efbe86e66c30cf674f1abdf051c1c /lang/cmucl/Makefile
parent0ff48101bd1fef4ecf977a46b5a8b4d6e891b6ea (diff)
downloadfreebsd-ports-gnome-c9f686c17dfbd8f9fdda127bb537100972d938ae.tar.gz
freebsd-ports-gnome-c9f686c17dfbd8f9fdda127bb537100972d938ae.tar.zst
freebsd-ports-gnome-c9f686c17dfbd8f9fdda127bb537100972d938ae.zip
The CMU implementation of Common Lisp, prerelease 18a
Diffstat (limited to 'lang/cmucl/Makefile')
-rw-r--r--lang/cmucl/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/lang/cmucl/Makefile b/lang/cmucl/Makefile
new file mode 100644
index 000000000000..f8be05ad1aea
--- /dev/null
+++ b/lang/cmucl/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: CMUCL
+# Version required: 18a
+# Date created: Jul, 15, 1997
+# Whom: cracauer@cons.org "Martin Cracauer"
+#
+# $Id: Makefile,v 1.5 1997/07/15 13:35:10 cracauer Exp $
+#
+#
+
+DISTNAME= cmucl-18a.x86.FreeBSD21
+PKGNAME= cmucl-18a
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp2.cons.org/pub/languages/lisp/cmucl/binaries/
+
+MAINTAINER= cracauer@cons.org
+
+NO_CONFIGURE= yes
+NO_BUILD= yes
+MAN1= lisp.1 cmucl.1
+
+do-install:
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} work/bin/lisp ${PREFIX}/bin
+ -$(MKDIR) ${PREFIX}/lib/cmucl
+ (cd work && tar fc - lib) | (cd ${PREFIX}/lib/cmucl && tar fx -)
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} work/README.1st \
+ ${PREFIX}/lib/cmucl
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} work/man/man1/cmucl.1 \
+ ${PREFIX}/man/man1
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} work/man/man1/lisp.1 \
+ ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
+