aboutsummaryrefslogtreecommitdiffstats
path: root/lang/cmucl
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-10-04 09:25:18 +0800
committeredwin <edwin@FreeBSD.org>2007-10-04 09:25:18 +0800
commitec40c1b18590a321d5dbd5ebbd73bea024902e87 (patch)
tree8e3df2c273b28d72e1077fa05e7244c8733a9f7a /lang/cmucl
parent7414fe7f0eb5384bcf0deaf5f4587f1c219c904e (diff)
downloadfreebsd-ports-gnome-ec40c1b18590a321d5dbd5ebbd73bea024902e87.tar.gz
freebsd-ports-gnome-ec40c1b18590a321d5dbd5ebbd73bea024902e87.tar.zst
freebsd-ports-gnome-ec40c1b18590a321d5dbd5ebbd73bea024902e87.zip
Remove always-false/true conditions based on OSVERSION 500000
Diffstat (limited to 'lang/cmucl')
-rw-r--r--lang/cmucl/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/lang/cmucl/Makefile b/lang/cmucl/Makefile
index be331c898d4f..f2ea9fb76766 100644
--- a/lang/cmucl/Makefile
+++ b/lang/cmucl/Makefile
@@ -19,6 +19,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-x86-FreeBSD
MAINTAINER= cracauer@cons.org
COMMENT= The CMU implementation of Common Lisp
+LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
+
# To make available on other archs, has to be cross-compiled (there is a
# script for this, but a configuration file has to be written).
IA32_BINARY_PORT= yes
@@ -29,13 +31,6 @@ MAN1= lisp.1 cmucl.1
PLIST_SUB= VER=${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-# portlint wants this earlier but this doesn't work because weneed OSVERSION
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKDIR}/bin/lisp ${PREFIX}/bin
cd ${WRKDIR} && ${FIND} lib | \
@@ -47,4 +42,4 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/doc/cmucl/* ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>