aboutsummaryrefslogtreecommitdiffstats
path: root/lang/cyclone/Makefile
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2005-04-12 11:26:56 +0800
committerobrien <obrien@FreeBSD.org>2005-04-12 11:26:56 +0800
commit3f8673b5304491d815979cbca9f5698f2e27e181 (patch)
treec5baddda5ee6043e9603695093e0628b6a5f6b85 /lang/cyclone/Makefile
parentc4111509081e059378dccea79903df7c1d4d2c75 (diff)
downloadfreebsd-ports-gnome-3f8673b5304491d815979cbca9f5698f2e27e181.tar.gz
freebsd-ports-gnome-3f8673b5304491d815979cbca9f5698f2e27e181.tar.zst
freebsd-ports-gnome-3f8673b5304491d815979cbca9f5698f2e27e181.zip
At Kris's request, back out the MACHINE_ARCH spelling correction until
after 5.4-RELEASE.
Diffstat (limited to 'lang/cyclone/Makefile')
-rw-r--r--lang/cyclone/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/lang/cyclone/Makefile b/lang/cyclone/Makefile
index 9f4534a79cb8..a5b8080725c3 100644
--- a/lang/cyclone/Makefile
+++ b/lang/cyclone/Makefile
@@ -22,9 +22,9 @@ ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PLIST_SUB+= DOCSDIR=${DOCSDIR:S/^${PREFIX}\///} \
- PORTBLD=${ARCH}-portbld-freebsd${OSREL}
+ PORTBLD=${MACHINE_ARCH}-portbld-freebsd${OSREL}
ALL_TARGET= all gprof aprof
CYCBINDIR= ${PREFIX}/bin
CYCINCDIR= ${PREFIX}/include/cyclone
@@ -32,6 +32,10 @@ CYCLIBDIR= ${PREFIX}/lib/cyclone
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500000
+BROKEN= "Cannot convert header files on -CURRENT!"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR} ${DOCSDIR}/online-manual