aboutsummaryrefslogtreecommitdiffstats
path: root/lang/diveintopython/Makefile
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2002-01-08 18:40:03 +0800
committerwjv <wjv@FreeBSD.org>2002-01-08 18:40:03 +0800
commit4fd0dab6956b915fc15fb9997fdeac286b4f75bd (patch)
tree0ea945c153c4b4e800a7c280ce66e98b31dce2d2 /lang/diveintopython/Makefile
parent11c1d2ab0982da077813d7cb7d914b3143ac8c35 (diff)
downloadfreebsd-ports-gnome-4fd0dab6956b915fc15fb9997fdeac286b4f75bd.tar.gz
freebsd-ports-gnome-4fd0dab6956b915fc15fb9997fdeac286b4f75bd.tar.zst
freebsd-ports-gnome-4fd0dab6956b915fc15fb9997fdeac286b4f75bd.zip
- Install examples to EXAMPLESDIR
- Fix file modes after installation - Bump PORTREVISION PR: 33461 Submitted by: Alan Eldridge <ports@geeksrus.net>
Diffstat (limited to 'lang/diveintopython/Makefile')
-rw-r--r--lang/diveintopython/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/lang/diveintopython/Makefile b/lang/diveintopython/Makefile
index 4cba33ba3ed5..992b0b5d6965 100644
--- a/lang/diveintopython/Makefile
+++ b/lang/diveintopython/Makefile
@@ -7,6 +7,7 @@
PORTNAME= diveintopython
PORTVERSION= 3.9.1
+PORTREVISION= 1
CATEGORIES= lang python
MASTER_SITES= http://diveintopython.org/download/
DISTNAME= ${PORTNAME}
@@ -42,10 +43,16 @@ do-install:
@ ${MKDIR} ${DIPDLDIR}
@ cd ${WRKSRC} && find *.html *.css images \
| ${CPIO} ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+ @ cd ${WRKDIR}/py && find * \
+ | ${CPIO} ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.for format in html html-flat pdf text examples
@ ${INSTALL_DATA} \
${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}-${format}-${VERSIONSTR}.zip \
${DIPDLDIR}
.endfor
+post-install:
+ @ ${CHMOD} -R ${SHAREMODE} ${DOCSDIR} ${EXAMPLESDIR}
+ @ ${CHMOD} -R ugo+X ${DOCSDIR} ${EXAMPLESDIR}
+
.include <bsd.port.mk>