aboutsummaryrefslogtreecommitdiffstats
path: root/lang/dmd2
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2011-06-06 23:13:14 +0800
committercy <cy@FreeBSD.org>2011-06-06 23:13:14 +0800
commitb007635b74f4e7965f0603c35005fccf97ecec67 (patch)
treec715e805ef64812c4a68b0f0ed958c3969c9f367 /lang/dmd2
parenta4d24bc1626cbb0114099d8d02ff6256e9343ac7 (diff)
downloadfreebsd-ports-gnome-b007635b74f4e7965f0603c35005fccf97ecec67.tar.gz
freebsd-ports-gnome-b007635b74f4e7965f0603c35005fccf97ecec67.tar.zst
freebsd-ports-gnome-b007635b74f4e7965f0603c35005fccf97ecec67.zip
Update 2.052 --> 2.053.
Diffstat (limited to 'lang/dmd2')
-rw-r--r--lang/dmd2/Makefile8
-rw-r--r--lang/dmd2/distinfo4
-rw-r--r--lang/dmd2/files/patch-druntime-src-core-stdc-math.d11
-rw-r--r--lang/dmd2/pkg-plist12
4 files changed, 14 insertions, 21 deletions
diff --git a/lang/dmd2/Makefile b/lang/dmd2/Makefile
index b3e47c533abe..f9ad74e4ffe5 100644
--- a/lang/dmd2/Makefile
+++ b/lang/dmd2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dmd
PKGNAMESUFFIX= 2
-PORTVERSION= 2.052
+PORTVERSION= 2.053
CATEGORIES= lang
MASTER_SITES= http://ftp.digitalmars.com/
DISTNAME= dmd.${PORTVERSION}
@@ -57,7 +57,7 @@ post-patch:
@${REINPLACE_CMD} -e "s|%@P%/../../src/phobos|${MODULEDIR}|" \
-e "s|%@P%/../lib|${PREFIX}/lib|" \
-e "s|%@P%/../../src/druntime|${PREFIX}/include/d/druntime|" \
- ${WRKDIR}/dmd2/linux/bin/dmd.conf
+ ${WRKDIR}/dmd2/linux/bin32/dmd.conf
post-build:
cd ${WRKSRC}/../druntime && \
@@ -69,12 +69,12 @@ do-install:
${INSTALL_MAN} ${WRKDIR}/dmd2/man/man1/dmd.1 ${MANPREFIX}/man/man1/dmd2.1
${INSTALL_MAN} ${WRKDIR}/dmd2/man/man1/dmd.conf.5 ${MANPREFIX}/man/man5/dmd2.conf.5
.if !exists(${PREFIX}/etc/dmd2.conf)
- ${INSTALL_DATA} ${WRKDIR}/dmd2/linux/bin/dmd.conf ${PREFIX}/etc/dmd2.conf
+ ${INSTALL_DATA} ${WRKDIR}/dmd2/linux/bin32/dmd.conf ${PREFIX}/etc/dmd2.conf
.endif
${INSTALL_PROGRAM} ${WRKSRC}/dmd ${PREFIX}/bin/dmd2
${INSTALL_DATA} ${WRKSRC}/../phobos/generated/freebsd/release/32/libphobos2.a ${PREFIX}/lib
${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKDIR}/dmd2/linux/bin/dmd.conf ${EXAMPLESDIR}/dmd2.conf
+ ${INSTALL_DATA} ${WRKDIR}/dmd2/linux/bin32/dmd.conf ${EXAMPLESDIR}/dmd2.conf
cd ${WRKDIR}/dmd2 && ${COPYTREE_SHARE} samples ${EXAMPLESDIR}
${MKDIR} ${MODULEDIR}
${INSTALL_DATA} ${WRKSRC}/../phobos/*.d ${MODULEDIR}
diff --git a/lang/dmd2/distinfo b/lang/dmd2/distinfo
index bffce6c8a13c..25eb8a8ab32a 100644
--- a/lang/dmd2/distinfo
+++ b/lang/dmd2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dmd.2.052.zip) = decd1fa193dd8f60cb41b4b7f887a761a766c557b0568d24b15aadc08d0f6742
-SIZE (dmd.2.052.zip) = 12669839
+SHA256 (dmd.2.053.zip) = 12df2090780d97ff2e0ebb8ed0867ba60b3a91aee9f8524a0149c17facda59b1
+SIZE (dmd.2.053.zip) = 15705351
diff --git a/lang/dmd2/files/patch-druntime-src-core-stdc-math.d b/lang/dmd2/files/patch-druntime-src-core-stdc-math.d
deleted file mode 100644
index 620975e3a877..000000000000
--- a/lang/dmd2/files/patch-druntime-src-core-stdc-math.d
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../druntime/src/core/stdc/math.d.orig 2010-11-30 13:56:26.000000000 +0000
-+++ ../druntime/src/core/stdc/math.d 2010-11-30 13:56:50.000000000 +0000
-@@ -479,7 +479,7 @@
- // but we can approximate.
- version( FreeBSD )
- {
-- version (all) // < 8-CURRENT
-+ version (none) // < 8-CURRENT
- {
- real acosl(real x) { return acos(x); }
- real asinl(real x) { return asin(x); }
diff --git a/lang/dmd2/pkg-plist b/lang/dmd2/pkg-plist
index d907e094f2df..f81efcded03c 100644
--- a/lang/dmd2/pkg-plist
+++ b/lang/dmd2/pkg-plist
@@ -31,8 +31,8 @@ include/d/druntime/import/core/atomic.di
include/d/druntime/import/core/bitop.di
include/d/druntime/import/core/cpuid.di
include/d/druntime/import/core/demangle.di
-include/d/druntime/import/core/dll_helper.di
include/d/druntime/import/core/exception.di
+include/d/druntime/import/core/math.di
include/d/druntime/import/core/memory.di
include/d/druntime/import/core/runtime.di
include/d/druntime/import/core/stdc/complex.di
@@ -100,16 +100,18 @@ include/d/druntime/import/core/sys/posix/time.di
include/d/druntime/import/core/sys/posix/ucontext.di
include/d/druntime/import/core/sys/posix/unistd.di
include/d/druntime/import/core/sys/posix/utime.di
+include/d/druntime/import/core/sys/windows/dbghelp.di
+include/d/druntime/import/core/sys/windows/dll.di
+include/d/druntime/import/core/sys/windows/stacktrace.di
+include/d/druntime/import/core/sys/windows/threadaux.di
include/d/druntime/import/core/sys/windows/windows.di
include/d/druntime/import/core/thread.di
-include/d/druntime/import/core/thread_helper.di
include/d/druntime/import/core/time.di
include/d/druntime/import/core/vararg.di
include/d/druntime/import/object.di
-include/d/druntime/import/std/intrinsic.di
include/d/phobos2/crc32.d
include/d/phobos2/etc/c/zlib.d
-include/d/phobos2/phobos.d
+include/d/phobos2/index.d
include/d/phobos2/std/__fileinit.d
include/d/phobos2/std/algorithm.d
include/d/phobos2/std/array.d
@@ -177,9 +179,11 @@ include/d/phobos2/std/mathspecial.d
include/d/phobos2/std/md5.d
include/d/phobos2/std/metastrings.d
include/d/phobos2/std/mmfile.d
+include/d/phobos2/std/net/isemail.d
include/d/phobos2/std/numeric.d
include/d/phobos2/std/openrj.d
include/d/phobos2/std/outbuffer.d
+include/d/phobos2/std/parallelism.d
include/d/phobos2/std/path.d
include/d/phobos2/std/perf.d
include/d/phobos2/std/process.d