aboutsummaryrefslogtreecommitdiffstats
path: root/lang/dylan/Makefile
diff options
context:
space:
mode:
authorhsu <hsu@FreeBSD.org>1998-07-13 05:58:13 +0800
committerhsu <hsu@FreeBSD.org>1998-07-13 05:58:13 +0800
commit2d971c6ac79d99c358ea3ae368692f967302c4a8 (patch)
tree93421f26869e4c54a0530d8b7c0daaa7266e6a26 /lang/dylan/Makefile
parent65a9463a6c5e756a2f67331889d41835621fb765 (diff)
downloadfreebsd-ports-gnome-2d971c6ac79d99c358ea3ae368692f967302c4a8.tar.gz
freebsd-ports-gnome-2d971c6ac79d99c358ea3ae368692f967302c4a8.tar.zst
freebsd-ports-gnome-2d971c6ac79d99c358ea3ae368692f967302c4a8.zip
CMU Gwydion project interpreter and compiler for the Dylan language.
Submitted by: Peter S. Housel <housel@acm.org>
Diffstat (limited to 'lang/dylan/Makefile')
-rw-r--r--lang/dylan/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/lang/dylan/Makefile b/lang/dylan/Makefile
new file mode 100644
index 000000000000..a31e130c5aa7
--- /dev/null
+++ b/lang/dylan/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Dylan
+# Version required: 2.0
+# Date created: 23 Jan 1998
+# Whom: housel@acm.org
+#
+# $Id$
+#
+
+DISTNAME= gd20-source
+PKGNAME= dylan-2.0
+CATEGORIES= lang
+MASTER_SITES= http://legend.gwydion.cs.cmu.edu/gwydion/dylan/release/
+
+MAINTAINER= housel@acm.org
+
+WRKSRC= $(WRKDIR)/src
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=$(PREFIX) --srcdir=$(WRKSRC)
+CONFIGURE_ENV= D2C="$(WRKDIR)/d2c -p$(WRKSRC)/d2c/compiler/platforms.descr"
+
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+ALL_TARGET= default
+
+post-extract:
+ uudecode -p $(FILESDIR)/d2c.gz.uu | $(GUNZIP_CMD) > $(WRKDIR)/d2c
+ chmod ugo+x $(WRKDIR)/d2c
+
+.include <bsd.port.mk>