aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ecl
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-25 20:58:33 +0800
committermarino <marino@FreeBSD.org>2015-03-25 20:58:33 +0800
commit5aae8d908d47fe8094dcc908ae88f162d9510445 (patch)
treeb03cfdc045d4887da1bbcf9872d0180f879152a5 /lang/ecl
parentbaa54cb73c8e4707d00379321c09d674a081b29f (diff)
downloadfreebsd-ports-gnome-5aae8d908d47fe8094dcc908ae88f162d9510445.tar.gz
freebsd-ports-gnome-5aae8d908d47fe8094dcc908ae88f162d9510445.tar.zst
freebsd-ports-gnome-5aae8d908d47fe8094dcc908ae88f162d9510445.zip
lang category: Remove $PTHREAD_LIBS
Note: ecl did not pass check-plist (pre-existing), PR 198897 submitted. approved by: PTHREAD blanket
Diffstat (limited to 'lang/ecl')
-rw-r--r--lang/ecl/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/lang/ecl/Makefile b/lang/ecl/Makefile
index 78e840ce3c80..fc8eaa17b444 100644
--- a/lang/ecl/Makefile
+++ b/lang/ecl/Makefile
@@ -70,7 +70,7 @@ CONFIGURE_ARGS+=--with-dffi=no
.if ${PORT_OPTIONS:MTHREADS}
CONFIGURE_ARGS+=--enable-threads=yes
-LDFLAGS+= ${PTHREAD_LIBS}
+LDFLAGS+= -lpthread
LIB_DEPENDS+= libgc-threaded.so:${PORTSDIR}/devel/boehm-gc-threaded
.else
CONFIGURE_ARGS+=--enable-threads=no
@@ -79,8 +79,7 @@ LIB_DEPENDS+= libgc.so:${PORTSDIR}/devel/boehm-gc
.if ${PORT_OPTIONS:MTHREADS}
post-patch:
- @${REINPLACE_CMD} -e 's|-lgc|-lgc-threaded|' \
- -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/src/configure
+ @${REINPLACE_CMD} -e 's|-lgc|-lgc-threaded|' ${WRKSRC}/src/configure
.endif
.include <bsd.port.post.mk>