aboutsummaryrefslogtreecommitdiffstats
path: root/lang/egcs
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2002-11-26 03:02:28 +0800
committerobrien <obrien@FreeBSD.org>2002-11-26 03:02:28 +0800
commit0453db28d3738d832be96945e00ba552c9b31541 (patch)
treeac769cd66e7823b68ffe4ef11456ffb39edbcd25 /lang/egcs
parentc1eb6cb434856002beecf189321d5a7a35824f8d (diff)
downloadfreebsd-ports-gnome-0453db28d3738d832be96945e00ba552c9b31541.tar.gz
freebsd-ports-gnome-0453db28d3738d832be96945e00ba552c9b31541.tar.zst
freebsd-ports-gnome-0453db28d3738d832be96945e00ba552c9b31541.zip
Rather than try to hack up the GNU strsignal (and psignal) to play nice
on 5-CURRENT, just use our native one.
Diffstat (limited to 'lang/egcs')
-rw-r--r--lang/egcs/files/patch-libiberty%Makefile.in8
-rw-r--r--lang/egcs/files/patch-strsignal.c11
-rw-r--r--lang/egcs/files/patch-va18
3 files changed, 22 insertions, 15 deletions
diff --git a/lang/egcs/files/patch-libiberty%Makefile.in b/lang/egcs/files/patch-libiberty%Makefile.in
new file mode 100644
index 000000000000..d8e34191a3ce
--- /dev/null
+++ b/lang/egcs/files/patch-libiberty%Makefile.in
@@ -0,0 +1,8 @@
+--- libiberty/Makefile.in.orig Sat May 23 15:32:53 1998
++++ libiberty/Makefile.in Sun Nov 24 14:17:03 2002
+@@ -120 +120 @@
+- strrchr.c strsignal.c strstr.c strtod.c strtol.c strtoul.c \
++ strrchr.c strstr.c strtod.c strtol.c strtoul.c \
+@@ -128 +128 @@
+- strsignal.o xatexit.o xexit.o xmalloc.o xstrdup.o xstrerror.o
++ xatexit.o xexit.o xmalloc.o xstrdup.o xstrerror.o
diff --git a/lang/egcs/files/patch-strsignal.c b/lang/egcs/files/patch-strsignal.c
deleted file mode 100644
index e746d2c9f45f..000000000000
--- a/lang/egcs/files/patch-strsignal.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- libiberty/strsignal.c.orig Sun Nov 3 21:38:47 2002
-+++ libiberty/strsignal.c Sun Nov 3 21:39:31 2002
-@@ -244,7 +244,7 @@
- #else
-
- #ifdef NSIG
--static int sys_nsig = NSIG;
-+static __const int sys_nsig = NSIG;
- #else
- #ifdef _NSIG
- static int sys_nsig = _NSIG;
diff --git a/lang/egcs/files/patch-va b/lang/egcs/files/patch-va
index 48040ffa6e96..c4d5b315bb30 100644
--- a/lang/egcs/files/patch-va
+++ b/lang/egcs/files/patch-va
@@ -1,6 +1,6 @@
---- gcc/Makefile.in.orig Thu Feb 25 12:40:16 1999
-+++ gcc/Makefile.in Mon Mar 1 04:36:40 1999
-@@ -793,7 +793,7 @@
+--- gcc/Makefile.in.orig Sun Mar 7 16:22:20 1999
++++ gcc/Makefile.in Sun Nov 24 23:51:04 2002
+@@ -768,7 +768,7 @@
rm -f config.run
$(srcdir)/configure: $(srcdir)/configure.in
@@ -9,7 +9,7 @@
# cstamp-h.in controls rebuilding of config.in.
# It is named cstamp-h.in and not stamp-h.in so the mostlyclean rule doesn't
-@@ -806,7 +806,7 @@
+@@ -781,7 +781,7 @@
# ??? Newer versions have a maintainer mode that may be useful here.
$(srcdir)/config.in: $(srcdir)/cstamp-h.in
$(srcdir)/cstamp-h.in: $(srcdir)/configure.in $(srcdir)/acconfig.h
@@ -18,3 +18,13 @@
@rm -f $(srcdir)/cstamp-h.in
echo timestamp > $(srcdir)/cstamp-h.in
auto-host.h: cstamp-h ; @true
+@@ -1914,7 +1914,8 @@
+ SYSCALLS.c.X: $(srcdir)/sys-types.h $(srcdir)/sys-protos.h $(GCC_PASSES) \
+ stmp-int-hdrs
+ -rm -f SYSCALLS.c tmp-SYSCALLS.s
+- cat $(srcdir)/sys-types.h $(srcdir)/sys-protos.h > SYSCALLS.c
++ echo "#define __NO_GNUC_VA_LIST 1" > SYSCALLS.c
++ cat $(srcdir)/sys-types.h $(srcdir)/sys-protos.h >> SYSCALLS.c
+ $(GCC_FOR_TARGET) $(GCC_CFLAGS) $(ALL_CPPFLAGS) $(INCLUDES) \
+ -aux-info $@ -S -o tmp-SYSCALLS.s SYSCALLS.c
+ -rm -f SYSCALLS.c tmp-SYSCALLS.s