aboutsummaryrefslogtreecommitdiffstats
path: root/lang/erlang-runtime15/Makefile
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2014-10-09 20:53:42 +0800
committerolgeni <olgeni@FreeBSD.org>2014-10-09 20:53:42 +0800
commita16d7155af2b2032519e905afbfc3247380aa69d (patch)
treea29bbe23fb42db47570063c9f28a9b909d05998f /lang/erlang-runtime15/Makefile
parent071e9a5954a2a5821f9ed2f4f929792a668e80fb (diff)
downloadfreebsd-ports-gnome-a16d7155af2b2032519e905afbfc3247380aa69d.tar.gz
freebsd-ports-gnome-a16d7155af2b2032519e905afbfc3247380aa69d.tar.zst
freebsd-ports-gnome-a16d7155af2b2032519e905afbfc3247380aa69d.zip
Reduce diff with the main Erlang port and unmute install commands.
Diffstat (limited to 'lang/erlang-runtime15/Makefile')
-rw-r--r--lang/erlang-runtime15/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/lang/erlang-runtime15/Makefile b/lang/erlang-runtime15/Makefile
index 3cfe73872f53..cbc88883c412 100644
--- a/lang/erlang-runtime15/Makefile
+++ b/lang/erlang-runtime15/Makefile
@@ -38,13 +38,14 @@ SCTP_DESC= Enable SCTP support
SMP_DESC= Enable SMP support
WX_DESC= Enable WX application
GS_DESC= Enable GS application (deprecated)
-DTRACE_DESC= Enable DTrace support (experimental)
+DTRACE_DESC= Enable DTrace support
OPTIONS_DEFAULT=SMP OPENSSL THREADS SCTP KQUEUE
ERL_RELEASE= R${PORTVERSION:S/.//g:tu:S/1$/-1/}
USES= gmake perl5
+USE_AUTOTOOLS= autoconf:env
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
@@ -62,9 +63,11 @@ DISTFILES+= ${ERLANG_DOCS}:erlangorg
# probes fixed does not match the number of defined probes (54 != 132,
# respectively)" you probably misconfigured DTrace in some way.
+.if ${OSVERSION} < 1000000
.if ${ARCH} == "amd64" && ${PORT_OPTIONS:MDTRACE} && ! ${PORT_OPTIONS:MGCC}
IGNORE= DTRACE support on amd64 requires GCC option
.endif
+.endif
.if ${PORT_OPTIONS:MGCC}
USE_GCC?= yes
@@ -160,17 +163,17 @@ MAKE_ARGS+= ARCH=x86
# links in the documentation.
post-install:
- @for SECTION in 1 3 4 6; do \
+ for SECTION in 1 3 4 6; do \
${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_MAN} \
-C ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB} \
"man/man$${SECTION}/*.$${SECTION}" || ${TRUE}; \
done
- @${RM} -rf ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/man/cat?
+ ${RM} -rf ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/man/cat?
.if ${PORT_OPTIONS:MDOCS}
- @${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_DOCS} \
+ ${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_DOCS} \
-C ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}
- @${INSTALL_DATA} ${WRKSRC}/lib/dialyzer/doc/*.txt \
+ ${INSTALL_DATA} ${WRKSRC}/lib/dialyzer/doc/*.txt \
${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/lib/dialyzer-*/doc/
.endif